Zodi Plays: The Legend of Zelda Phantom Hourglass (I specifically asked for less water)

actionadventure
informative
video
humorous
subtitled

#21

Okay, let’s do a Zeldo

Zodi Plays: The Legend of Zelda Phantom Hourglass [9] Ocean, Again

Video Length: 26:33

In today’s exciting episode, we head back to the Ocean King’s Temple to once more plumb it’s depths. But before we do so, let’s check up on a few of the boats lingering in the North Eastern Sea. Beedle is one, and it is here I’m reminded that his shop sells different stuff depending on the region he is in, and his masked ship probably does the same. That’ll be rough. Also rough, I do NOT have enough rupees to buy the bomb bag, which I’d very much like to have right now. Unfortunately I also decide the cash is burning a hole in my pocket so I buy us a nice gem. After that, we head to a mysterious long-ship that turns out to be…the Prince of Red Lions, piloted by a rather suspiciously dressed individual who believes himself to be a hero of some sort. We train a bit…and by train I mean terrify him with our sword, and he rewards us for it. We’ll be back to train more COMPLETELY with Nyeve here later, because I forget how to make him willing to do more. And because I definitely don’t have time to do 100-200 hits on him just yet.

With those distractions out of the way, we finally return to Mercay Island, and wander our way up to the Ocean King’s Temple. With our bombs and shovel in hand, we do have SOME access to new things. First off, on the walk up to the temple, we can blow up some rocks to get a shortcut to the temple (not super relevant considering how short the other path is) and blow up a rock wall that leads to some treasure, and further mysterious interactables. Within the temple itself, the first two real floors get a shortcut with the bombs, though of these the first one is a bit more significant than the others. Floor B3 has basically no real shortcut, since the shovel point really doesn’t accomplish much that isn’t just as easy to perform otherwise. But finally, after all that, it’s onto new content. And what new content it is!

B4, the start of the next bit of new content, introduces us to a…contentious new friend. The Phantom Eyes! The eyes of the Phantom, they have a…finicky view range that is not even remotely shown on the map, and once they see you they become invincible and alert every single Phantom on the floor to your location. They also sometimes SUMMON more Phantoms, so that’s always fun. Thankfully, if you do catch them unaware with the boomerang, you can kill them and that solves that. And on this floor you even get a treasure chest for doing so! The puzzle otherwise is just navigating a wind maze without being caught out, so it’s easy enough. Onto B5, which…is less puzzle and more combat challenge. This is honestly appreciated, since a ton of puzzles in a row isn’t always the best gameplay. Sometimes you need to break it up with some combat…though given it’s Phantom Hourglass’s combat, that’s a small blessing to be sure.

The last room, B6, is another example of how the game feels trickier than it is. There are six tablets, and the four in the corners tell us the order we should care about them, while the middle two tell us “hey care about the order” and…just kinda rudely dunk garbage onto us without any warning at all? It’s super bad and probably the worst thing we’ve encountered in this game up till this point. Reading this tablet, without any warning, drops two more Phantom Eyes into the room, at rather inconvenient spots. It’s not that big a deal in the grand scheme of things, but it’s a level of rudeness you wouldn’t often expect from Zelda, and one that is very much not appreciated since it implies we’ll probably end up with MORE rudeness like this later. At any rate, we draw ourselves a hourglass symbol, and make our way into the room of courage, wherein we find a fun little sun mural telling us how to get to the next temple! All we need to do is press our map into the stonecuttig on the mural. This is one of the most iconic, memorable puzzles in the game due to how it takes advantage of the DS in I think interesting, relevant ways. With our map marked with a little courage symbol sticker, we can now safely…have no idea what to do with it. But the hintings at a Salvage Crane makes me PRETTY sure what we can do next.

Before that though, we check out the now open Treasure Teller! He appraises our treasures and ship parts, and we can sell them to him for rupees. The price he assigned each ship part set and each treasure is entirely random, determined when you start the game…and it turns out most of the stuff I have right now is garbage! Thankfully, I know not to sell to him just yet. There’s a store out there that buys certain items at a rather high price…it’s just that this is also determined randomly. Sweet. It’s to encourage connecting your game with other players, but as someone who is flying entirely solo that doesn’t really help me much. It also just feels bad to have all this treasure and be told it’s not worth much. But ah well, it wouldn’t be Zelda if there wasn’t at least one finicky and weird mechanic.

But that’ll be it for today. Join us next time when we finally obtain the Salvage Arm, and set about…probably trying to get treasure from under the sea, but also probably progressing things. We’ll see. Hope you all enjoyed!


#22

Can’t say I’m fond of B5 just being enemy gauntlets in rooms without safe zones. At least it’s easy to skip over the floor, maaaaaybe even in the next visit? I can only ever remember going down there once a run anyway.

The seachart puzzle rules, though. I solved it completely by accident by taking a break while trying to figure it out.


#23

Second person I know to solve it that way! Given very few people played this game, you’re part of a pretty exclusive club. Which rules, to me at least.

Also yeah the combat room is…a mixed back. No safe zones makes it a bit annoying.


#24

Oh man. Z E L D A.

Zodi Plays: The Legend of Zelda Phantom Hourglass [10] The Arm

Video Length: 20:16

Bit of a short one today! You’ll see why.

Starting us off today, we head to Fuzzo’s work shop to get the Salvage Arm. The only problem is…he recognizes us, and wants us to show how much we want the Salvage Arm. So we need to shout it out. And he does mean literally shouting. I am…not a big fan of this, especially because if my DS’s mic was even a little bit worse I would be stuck here! Additionally, the LEVEL OF SHOUT you do determines how cheap the arm is…ranging from 200 to 1000 rupees. This is absurd, personally. And to cap it all off, once you finish it…his apprentice notes you can just snap your fingers and it’s fine. There’s egg on my face, because I did actually shout the things I said in this. It…was a thing.

But of course that couldn’t be the actual end of our troubles today could it. With Salvage Arm in tow, we head to one of the first optional salvage points we have to get some treasure. And instead we get a terrible touch based minigame, wherein we control the arm from the very bottom of the screen. Hold down to speed up, hold up (but still at the bottom of the screen!) to slow down. You also control it by shifting the little lever we’ve got as a visual aid left or right. We need to avoid Octomines as we do this, with the occasional bubble of rupee in our path, and at the very end is a treasure chest…a chest that we can miss, making the entire lengthy process moot. But if you DO grab it, be prepared to do the exact same thing again, since you’ve gotta drag the chest back up to the surface! This of course makes your salvage arm a bigger target for smashing into rocks or Octomines. But, you may ask, what happens if you get hit? Well, you lose a point of durability, of which you have five, and only ever have five. These can be repaired at Mercay Island, and only Mercay Island, for 20 - 50 rupees. Unlike the ship proper that heals every time you make land fall. And if you let the salvage arm be destroyed? Or more accurately, the game has currents that you can’t see, making the arm not respond, or the absolutely garbage finicky controls make it hard to control the crane? Well, if you get destroyed…you can’t Salvage anymore. You need to go to Mercay Island, and only Mercay Island, to get it repaired for 100 rupees. Until then you cannot use the Salvage Arm. At all.

This is the part of the game where I’m reminded WHY I can’t remember basically anything about this game. It’s a hell of a thing, and probably…one of the worst mechanics I’ve seen in a video game. A friend of mine was playing Xenoblade Chronicles X and they make you do a minigame like this to upgrade the one robot player character, and it has basically no stakes beyond wasting time. And HE despised it. THIS, this is WORSE, because not only is it a large amount of time to perform, it’s also…much harder to control, and with actual consequences if you lose too much. We will not be doing any salvage that isn’t required until end game, JUST because we cannot repair the crane ANYWHERE else but Mercay Island. And even then it won’t be that easy for reasons we’ll go over then…

So, the above aside, what else have we done today? Well, we saved Nyave again, and got a comical amount of treasure. That was really funny, actually. We also did do that one bit of required salvage, obtaining the sun key! With the Sun Key in hand, we returned to Molida Island…to be faced with a boss! The Giant Eye Plant, which…is a giant Eye Plant. It spits goo at us, but we can easily shoot it out of the air. It is a very simple boss, with barely any thought to it beyond having to steer the ship every so often. Once more I feel the monkey’s paw curl as something I ask for is delivered to me. But, it’s relatively harmless, so we make our way to Molida proper and do a quick little jaunt to the Sun Door. We turn these weird laser shooting rocks to face the door to our next Temple, unlock it, and call it there. Next time on Zelda, we’re gonna do the FUN thing about this game: actually very good dungeons!

I hope you all enjoyed this hot mess. I’ll see you guys next time!


#25

Happy Canadian Thanksgiving to all you wonderful peeps out there. Here’s some Zelda to go with your absolutely nothing special since most of you are American.

Zodi Plays: The Legend of Zelda Phantom Hourglass [11] Courage

Video Length: 21:13

Bit of a shorter one today as well, though this time NOT because of a bad bad gameplay mechanic, but simply because Zodi is a dumb and spent 4 minutes on a puzzle due to a complete disconnect mentally on what specifically it asked me to do, plus getting left and right mixed up.

Anyway, today we start the third dungeon, the Temple of Courage! This one is quite a bit larger than the other ones, with a bit more challenge to it as well. We’ve got rolling spike logs, blade traps, and a bunch of other nasty traps to contend with. We’ve got more than our fair share of bombable walls, most of which are hidden decently well but still fairly, and we’ve got a couple pretty good puzzles as well. We also have enemies, which is unfortunately where the dungeon lags behind in terms of quality. The Green Chu-chu’s are…frustrating, and I really don’t know how to handle them. They dodge into goop when you slash at em, and there really doesn’t seem to be any rhyme or reason for when you can hit them vs when you cannot. I think the idea is to wait until they ungoop, because then they’ll be a little tired, but even then it doesn’t work half the time. A thought occurred just now to try using bombs…but spoilers this is the only place they show up so we’ll never get the opportunity to! We also meet Pols Voice, a classic enemy all the way from Zelda 1. These bunny head monsters are invulnerable to most attacks, but if you give em a good shout they’ll be stunned, become quite vulnerable. In previous games, arrows could deal with them, so I’m unsure if we NEED to shout in this game, but you probably do. We’ve also got Hardhat Beetles, cute little bugs that can’t really be destroyed, merely deflected. Toss them into the pit to kill them for now. Finally, we’ve got Moldorms, who are entirely armoured centipedes except for their tail weakspot, which must be struck to kill them. We’ve also got Beamos and Winders (flowing orbs of electricity that go along the walls) but they can’t be killed, and Beamos can only be stunned by bombs.

Speaking of arrows, once we get past an invisible walkway we find the dungeon item, the hero’s bow! Thanks to touch screen technology, the bow is rather accurate for the most part, allowing for full 360 degree aiming. Unfortunately you also can’t MOVE while using it, much like the boomerang, so it’s use in the heat of combat is tricky. It can destroy a Moldorm in one hit, but getting that hit is finicky and not worth the waste of arrows. The bow, like the boomerang, is mostly a puzzle interaction device. Shoot the eyes to trigger things, shoot these little arrow orbs to send the arrow flying in a direction…usually into another eye. It’s fun, and pretty neat actually. Seeing your arrow fly across the entire dungeon to peg a poor loser in the face to make a chest appear has a certain good feel to it.

The Temple of Courage has a unique bit to it, in that most of it’s puzzles follow a certain pattern. Up, down, right, left. A simple one, but important to remember, since many of the puzzles relate to it. Unfortunately, or fortunately depending on your point of view, not every puzzle follows it. I feel like it could be cool if they tried to make every puzzle follow this pattern, but I totally get why they didn’t. Most of the puzzles that are major do though, like those switches I got held up on for four minutes. I was confused because I thought it was a trick, that you pulled the switches based on their DIRECTION, not their LOCATION. But then I realized they didn’t have any that would be pulled up! So I go to pull the switches in the dungeon order based on location…only to mix up left and right. Womp womp. This, combined with actually just outright missing the stairs at the end of the video, are why this one is a bit shorter.

That being said, I hope you all enjoyed! I’ll see you guys next time for when we beat the Temple, so prepare yourself for a boss fight. And then…prepare yourself for the Ocean King’s Temple, because we’re gonna have to go through all of it again. Every single room we’ve seen so far…again.


#26

Hey let’s…do some more Zelda? That sounds like a good idea.

Zodi Plays: The Legend of Zelda Phantom Hourglass [12] Crayk

Video Length: 18:34

Another short one today, for reasons that will quickly become apparent. Mostly in that since Past Zodi forgot how immediately close to the end she was. Because really in retrospect this…entire video, more or less, could fit in the last video, just it would require a bit more editing on my part. But regardless, let us continue!

The final room of the dungeon is…a rather interesting gimmick. You get on a large cube, and if you draw on the map it will follow the line like a moving platform. This is sadly not the best programmed mechanic, the platform being a bit finicky and the actual resetting of it’s path being…a bit of a mess. This room also has the unfortunate, though for me quickly realized, point of having four eye switches you need to hit in the dungeon’s mystical order of up down right left. If you don’t realize that as quickly as I did, you’re gonna be spending a lot of time floating on cubes. With the big key acquired, we can now go fight the boss…after getting that final treasure chest (I think final, anyway…).

So, what’s the boss of the Courage temple? Well, none other than Crayk, Bane of Courage! A huge hermit crab monster, which spawns little babies called Crayklings, this meaty clawed monster has a really interesting gimmick that makes use of the top screen in a fun way. Making Blaaz the only boss of these three to not really utilize the top screen in an interesting, enjoyable way (since it’s hard to aim the boomerang precisely when they’re all moving around). In this case, the top screen shows us Crayk’s vision! On our screen he is invisible, so we’ve got to use his own sight to see where he is, and shoot him with an arrow! Once he’s stunned that way, we can smash the crystals on his shell. Once THOSE are destroyed, his shell breaks off and he enters his second phase! In this phase his only real attack is running up to you and, after pausing for a moment, lunging at you to grab you. Now, what you’re supposed to do here is show your bravery, your Courage! You stand your ground, arrow held out, and once he’s about to strike you arrow his eye, stunning him so you can get behind him and slice at his weakpoint. It’s really cool, and one of the few times Zelda in general has presented Courage across in it’s mechanics. It’s really neat!

Past Zodi does not have time for courage. I…entirely blanked on that being how you beat Crayk’s second form, and instead just tactically threw my boomerang at it to briefly stun it long enough for me to get behind it. I feel like that’s cool, but not as impressive or interesting as the intended method. At any rate, Crayk has been turned to Sand, and we save our third fairy…sort of. It’s lifeless and floppy, and it looks like Ciela which is weird but nothing seems to be happening with it. We even get weird, somewhat mysterious item get music. What strange mysterious this game holds. We also get our heart container, and with that we can now…return to the Ocean King’s Temple. At least I think so, the game says maybe we can find the Ghost Ship now but I’m honestly not…sure what happens next. Which is a problem this game has, there’s really no fanfare at all once you beat a dungeon. In the other games we’ve played so far in the Zelda series, when you beat a Dungeon, a lot was made of it. You beat it, you solved the Problem, and the game helped point you in the right direction now that you can go back to the free world again. In this game…it doesn’t really reward you for beating the dungeon beyond the rewards you get for beating the dungeon, so it feels odd. I don’t know, maybe it’s just me, but it carries this weird feeling of dissatisfaction, even in good dungeons like the Temple of Courage.

Speaking of dissatisfaction, as we return to the village, we find that ole Romanos has opened up a minigame in his house! It’s an archery minigame, where you’ve gotta shoot ghost targets while avoiding girl targets. It’s a simple enough minigame, making use of the top screen in a decent way. It’s…a little tricky due to how the aiming works, I really feel like the bow should have a targetting line or something. If you get close to his highscore of 1700 points, he gives you a random Treasure reward. If you beat his highscore, you get the Quiver! A very useful tool indeed. If you beat his highscore again, you get random treasure pieces. And finally, if you beat 2000 points, which I believe is basically a perfect score, you get a heart container. This took me…a lot of time, and by the end of it my hands hurt and my soul was crushed. It’s a surprisingly agonizing minigame, since it feels really easy and you get into a groove and just twang twang twang all the targets. But one miss, one little screw up, and your rhythm is crushed and you screw up a ton. It’s pretty disheartening. Also I used up almost all my money here, but the treasure and ship parts I got should help ease that pain…once I find a place to sell the former, anyway.

But yeah, that’s today’s video! Like I said, a bit of a short one. This recording session was plagued with “minigame makes the video shorter than average” and that bugs me. But as you could no doubt tell, I wanted to get some of this stuff out of the way so it doesn’t loom over me for the final clean up. But yeah, that was this. Hope you all enjoyed, I’ll see you guys next time!


#27

Almost didn’t get this one done in time. Preparing to move is rough.

Zodi Plays: The Legend of Zelda Phantom Hourglass [13] This One Has Ghosts In It

Video Length: 24:00

Last time we beat up the Temple of Courage, which means our next destination iiiis…not the Ocean King’s Temple! I completely forgot what happens next, and as it turns out it’s a bit different. First though, we head to port to leave…only to see old man Oshus is here! It is here we learn the stunning truth, Ciela is the Spirit of Courage! The spirit we collected from Crayk is just her discarded memories, which she split off from for some reason. With the help of Oshu, Ciela is able to finally reunite and become the Spirit of Courage…which shines yellow. I’ve theorized about Ciela being yellow because of colour blindness issues, since she is most often your pointer, but…there really isn’t any reason at all beyond “she’s your fairy friend so she has to be shiny and white” for her NOT being green. It’s a shame, because every courage thing is marked as green EXCEPT her so it really stands out as an issue, to me. A minor one, but one that still bugs me. Regardless, we have the three Spirits now, which means we can finally find the Ghost Ship! So we head off, ready and willing to face our dangerous foe with power, wisdom, and courage.

Of course we get interrupted on our way there, by Jolene! Seemingly an old friend of Linebeck, her ship attacks with torpedos and if she gets too close she boards you. Linebeck tells you to run away from her…don’t. If you fight her you get a money reward from Linebeck, and while that starts small it’ll eventually get bigger and bigger! So definitely beat up Jolene as often as possible. It’s a decent source of rupees. It’s also just fun, personally. She’s a simple fight, swinging her sword and doing lunge attacks that leave her vulnerable, but it works. It feels suitably exciting for this engine. That distraction taken care of, it’s time to chase the Ghost Ship for real! And by that I mean we enter the fog to pursue it and then our engine breaks down immediately.

This part is…less than good. With the engine broken down, all we can really do is cruise. But since Linebeck is busy fixing the ship, he can’t steer. That leaves it up to us to steer, and the controls are…finicky, to say the least. We move by touching left or right on the screen, and we just kinda hope it works out. The spirits are here to act as a dowsing rod mechanic to find the Ghost Ship, but it’s very imprecise, as you’d expect, and the ghost Ship is always moving and starts pretty far away from you. The spirits only respond positively if you end up pointing them DIRECTLY at the ship, so it can be pretty hard to gauge where it actually is. It’s kinda bad, but thankfully doesn’t take TOO long. We finally find the blasted thing after a sped up amount of sailing, and board it. It’s time…for a mini-dungeon!

As far as dungeons go, “mini” is definitely the term for it. There isn’t much to this one. It’s got three new enemy types, consisting of the weakest and most dangerous enemies in the game! We’ve got Skulltula’s, who just drop from the ceiling and sit there, doing nothing. We’ve got Poes that warp around, turn invisible to avoid attacks, and spit ghostfire at you. They’re surprisingly tricky, especially since our first encounter with them goes super well. And finally we have Reaplings, who are just Phantoms but if they’re alerted by sound can go through walls, and instead of dealing health and time damage, they just rip like four hearts from you. It sucks a lot! The worst of it though is the gimmick of this dungeon…the Cubus sisters. These…decidedly obviously evil girls inhabit the dungeon, and you’ve gotta save em! They might know where Tetra is and are definitely not evil at all. That’s right boys, it’s an escort mission. If a Skulltula gets even remotely close to one they’ll freak out, and if Reaplings are around the girls cannot be shaken out of their screaming fit. This is incredibly frustrating, but really that’s this dungeon in general. It’s got a great spooky aesthetic, but it’s just not quite as good as it could be. And it’s ruined by tiny awful children and treasure chest traps that there are no warnings for, until AFTER you’ve most likely hit the treasure chest trap in the first place.

But yeah, that’s the dungeon. And we’re about half way down with it by the end of this video. Hope you all enjoyed, I’ll see you guys next time for the conclusion of the Ghost Ship, and perhaps the saving of Tetra? That’d be cool, get us some sassy pirate princess in here.


#28

Onwards, to more garbage child saving simulator. I mean Zelda.

Zodi Plays: The Legend of Zelda Phantom Hourglass [14] Cubusi

Video Length: 25:17

Starting us off today, we head down to the lowest reaches of the Ghost Ship to find the last Cubus sister. The last floor actually has a neat puzzle in the switches that are immediately accessible, plus an honestly pretty funny trap that leads to my falling down quite embarrassingly. But it’s funny, so I don’t mind all that much. The puzzle in question is just a simple order of numbers, but…maybe I’m just weird, but I definitely overthought this one. It lists the order of the switches we have to pull…but for some reason I thought the order was to be read left to right, and you pull the POSITION it lists. So it says 4 is in the first spot, so you pull the fourth switch. This is…obviously, incorrect, you just pull the switches 1 through 5, and the numbers tell you which number is aligned with which switch. But I think my answer is actually potentially valid! It’s at least a slight look into how certain puzzles have potential for oversight. Another feature of this floor is a treasure chest. Now, the girl we find this episode never says boo about the chest, that I recall, and that might be because I opened it before acquiring her, but I feel like the intent of this is that you opened the Rupoor chest last floor, so you won’t open up this one. This is a mistake, trust only your fists and open that bad boy up to find a large red rupee, worth 200 smackers! That more than makes up for the loss we had last time. Additionally, once we actually get the final Cubus sister, she gives us a decent hint! Shoot arrows at the Reaperlings to stun them. Of course she says so in her devious trickster way, but I feel like it should be pretty obvious that you should do the opposite of what they say at this point.

Bringing the final Cubus to her sisters, they reveal that, dun dun duuuuuh they’re evil, some kind of Poe or demon (they ARE called the Cubus sisters after all. They’re children, so they don’t have the suc part yet since that’d be gross) that inhabit the Ghost Ship and apparently beat up Tetra. And now it’s up to us, and they’ll do to us what they did to Tetra…DEAD MAN’S VOLLEY. Yup, that’s right. It’s time to do a tennis. In this game. This game blessed by the Gods to not have any precision what so ever. It’s…not as bad as it seems, but it’s definitely not as fun as it looks either. Each of the Diabolical Cubus Sisters takes turns shooting the tennis orb at you, while the others play around with lasers. It’s honestly not that complicated, but in comparison to the other bosses in this game it’s not super great. It’s strange, thinking on it, but Phantom Hourglass has had some phenomenal bosses. The Giant Eye Plant was bad of course, and Blaaz’s weakness is a bit RNG-y, but on the whole the bosses have been real good in this, from a design, mechanical, and just style standpoint. At any rate, once we’ve killed all but the last Cubus, she starts shooting triple shots, only one of which you can hit safely. Gotta be extra precise here! Thankfully, the game is kind enough to give a surprising amount of leeway in hitting the tennis orb, so I take her down fairly quickly and get our reward; a heart container that you can miss if you don’t pick it up right here, right now, and the ghost key that’ll let us find Tetra.

And find Tetra we do…drained of life, petrified in stone. Linebeck appears, our killing of the Cubus Sisters stopping the mist and effectively making the Ghost Ship nothing more than a legend. It looks…fairly grim for us. But then who should appear but old man Oshus himself! In another surprise twist that some of you even noticed; he’s the Ocean King, dun dun duuun! I feel like this is a legitimate twist, unlike the Cubus sisters, because you could easily just assume he’s a sage of the temple and just the actual big man himself. but yeah, Oshus reveals himself, and then reveals the actual backstory for this game. Bellum, a squirming eye, a demon that seeks out life force. Life force that once it’s consumed, turns to sand. He fought with, and is still fighting really, the Ocean King, deep within the temple. The Oshus we see here is but a fragment of the great Ocean King. With his magic he was able to create the Phantom Hourglass, which runs on the Sands of Time, lifeforce itself. We get a…really good callback to the beginning of the game here with Oshus’ story about Bellum, with suitably creepy pieces of art that show the last three bosses we took out; Blaaz, Cyclok, and Crayk. Each marked with those unblinking, glaring eyes of Bellum. Those same eyes appear on the back of the Reaplings and Phantoms, so that’s cool. Of course, after his story, Linebeck is…unsatisfied, he wanted treasure dangit! He won’t let us use his ship unless he gets any. Oshus, shrewd old god that he is, promises Linebeck he can have one wish. After all, it’d be plumb rude to ask for him to do it for free. I really, really like this scene, because it’s hilarious and Linebeck is such a craven, moronic, self serving idiot coward asshole…who is entirely, completely, overwhelming easy to manipulate into doing basically whatever. His personal theme is also a banger of a track that really gets the blood pumping.

With a ship assured, we sail off to an uncharted island south of the Temple of Wind. There we meet the Blacksmith Zauz (and also experience actual mail fraud) who tells us of how we can continue our quest. In order to slay Bellum, we’ll need the Phantom Sword. But to get that…we’ll need to find the three rare metals that go into forging it. We also need to find more maps in the Ocean King’s Temple, and he gives us the solution to finding more dungeon! Draw a triforce on that gate we drew the hourglass on, an actually interesting puzzle since you need to figure out how to draw a triforce in one stroke. I’m all for a new sword, but I for one actually want to make a note of how Zauz…very much looks like a Gerudo, and is male. It appears we may of found the last remnants of the Gerudo in this flooded era, and it’s a dude! That’s cool, to me. For a variety of reasons. But that’s all I have to say, for now. I hope you all enjoyed, I’ll see you all next time for…more Ocean King’s Temple. The Ghost Ship may of put it off for awhile, but it was inevitable.


#29

Onwards, to move Zelda!

Zodi Plays: The Legend of Zelda Phantom Hourglass [15] Gem Puzzle

Video Length: 28:49

In today’s exciting episode, we…sort of meander our way back to Mercay Island to do more of Oshus’ Temple. Along the way we meet up with the “defender of the seas” once more, this time letting us hit him three times before immediately caving and giving us some treasure. We also meet Jolene again, and get paid 20 rupees as opposed to the piddly 5 we got last time. That’s a pretty sizable raise! Once all the sailing is said and done, we make landfall at Mercay Island. Immediately we’re met with…an odd letter from Linebeck himself, where he thanks us for being such a cool pal. See, Linebeck is great! He even rewards us with a ship part! We also finally dig up that secret we got alerted to, finding…a treasure chart, sadly. Less sadly, I was reminded to go check out the price for my coral…and as it turns out it’s 1500 rupees! So yeah there’s not gonna be a money problem for us for…awhile. With all that cash burning a hole in our pocket, we buy the final quiver upgrade at the store here, and make our way to the temple! Though not before we’re interrupted by a villager wanting to give us a treasure chart, and more importantly tell me that a big golden frog is where the second X on our map is. We’ll be tackling that next time, as I forgot that was doable now!

Of course, while I did say we’re doing the temple next…the actual next thing we’re doing is opening up that eye switch in the run up to it. It has a minor bit of fighting beyond it, but more importantly it leads us to a (relatively simple) puzzle. Aim the shining head laser perpendicular to a thing, and it’ll hit a wall that’s secretly weak to explosives! We do so, and easily blow up the wall without any actual problems. I’m actually able to do one of these puzzles correctly first try, woo! Unfortunately our reward for it (beyond an orb or two) is…not super useful. It’s Freedle the mystery bard, in charge of the spot pass mechanic for this game. And since I’m the only person up where I am who likely owns this game, the ability to trade treasure and ship parts with people is…a nonstarter. We won’t be seeing Freedle again, unfortunately. Which is a shame, his music is pretty nice.

Finally, it’s time for the Ocean King’s Temple. And if you thought we were just going to have a regular old time getting down to the bottom floor…think again. Bellum is aware of our progress, his eyes are everywhere, and he’s mad. Every floor has received an upgrade of at least one Swift Phantom, red versions of the Phantoms who are faster than their durdling counterparts. There is no actual other difference though, so we won’t actually see much of the old floors of this temple anymore. We finally manage to cut our way down to the crest door, which we scrawl the sacred triforce symbol into, opening the path! But, more importantly, this gives us…our first check point! It saves our time once we’ve reached it, and if you return to the temple the normal way you can shoot for better times (which we may do) but ultimately…this is our staging ground. We’ve finally found a check point! Which means…the game’s about to get a lot harder. Any kid gloves that where on this multi armed behemoth are entirely removed now, as the next leg of our journey requires a three floor puzzle to be solved, with multiple dead ends or points of no return, with nasty Phantoms and devious traps. Invisible floors litter the place, and we encounter the newest in anti fun technology; noise floors! And unlike say, bombs or sword hits, the Phantoms DEFINITELY hear these. We also encounter a new enemy, the Wizrobe! They sneak up on you and try to drain time from you with their scythe, but if you beat em up 30 seconds of sand drops out. That’s pretty good, honestly. We also are told to shoot Phantoms in the back, as they have the same eye vulnerability the Reaplings had.

As said, the puzzle we need to do to open our way to the last Sea Chart is spread across three pretty large floors. We need to lug those gem keys around, which slow Link down to a crawl. This actually helps a bit, since it means Noise Floors are no issue. It’s still a little annoying, though. Phantoms can pick up any stray gems they find, so you can use them as lures to get Phantoms into the position you want as well, which is pretty useful actual. But yeah, we lug the three keys down…only to hear from a skeleton that if we put them in in a certain order, we’ll be rewarded for further progress! Ciela asks if we want to do that right away, or just leave now that we have the sea chart. I actually like this, the idea that if you think you have enough time you can blaze through the Ocean King’s Temple…except I don’t imagine for a second it’s actually possible without the next dungeon item, so it’s really a false choice when all is said and done. But yes, with sea chart in hand, that’s it for today. I’ll see you all next time, where we go clean up some stuff we encountered in this video…and then make our way to the newest portion of the ocean!


#30

So, the first visit to the 7th floor set is probably my least favorite part of Temple of the Ocean King. It’s an incredibly overwhelming puzzle to have to deal with on your first visit, and even replaying the game, not having the tools to make those floors more convenient makes them kind of a pain.

Also, since I was late for the previous update, the heart container you get from the Ghost Ship can actually be obtained if you skip it. You’ll get it in the mail if you do, though I looked it up and you can say no to receiving it, at which point it will be gone forever. Which I guess is a mercy to people who want to do a 3 heart run.


#31

Huh, I didn’t realize that.

Also yeah the 7th floor is…a bit much. But “A bit much” is really the Ocean King Temple in general.


#32

Hmm. Controversial idea: more Zelda.

Zodi Plays: The Legend of Zelda Phantom Hourglass [16] Mermaids

Video Length: 29:19

Starting us off today, we leave the Ocean King’s Temple, only to be accosted by skeletons asking us for pocket change in return for hints. I actually do not know what stuff they could possibly tell to us, so I opt out for the time being, but we’ll give it a look later probably! Afterwards we head to the shop to buy that Power Orb…only to find it’s still not there. I think I MIGHT of bought it without erasing it, but that might be me mixing it up with the orb on Molida. I’m actually fairly certain the shops just have a rotation and the orb is out of rotation at the moment. Which feels incredibly weird, and not at all proper. Regardless I’ll keep an eye out for this mystery orb. We do manage to buy the Bomb Bag from Beedle, giving us a far more healthy number of bombs. If it wasn’t immediately clear, today’s episode is going to be a bit of a clean up episode as we sail around finding garbage and beating up people. We check in with all our resident side quests to try and progress them a little, get some minor rewards (and major ones, thanks to Linebeck being the best) and do some Salvage, wherein I finally learned a way to actually control the Salvage Crane in a reasonable way! Which is to say, don’t. Just let go of the controls when you’re done moving it. It’s slow going, but the only time being burnt is mine so it should be fine!

In terms of actual importance, we go to Spirit Island to cash in our ten Power Orbs so we can power up Leaf. As long as Leaf is selected as our targetting reticule, our sword will now be on fire! This doubles our damage output, which…is not actually all that relevant given how few enemies there are in this game that don’t die to one hit, and the chunkiest enemy we know dies to one combo anyway. However, the secret power of the flame sword is that it lets us hit Phantoms (and Reaplings if they ever show up again) in the back with our sword, letting us stun them without using our arrows! This is minorly useful, but still decent enough. After that we head to the uncharted island where the fabled gold frogs are said to live, and have to tackle an actually rather interesting puzzle involving mapping out said uncharted island, then hitting the gossip stones in order. Our reward for doing this is a meeting with the Golden Chief, the frog boss and cyclone lord of this region of the sea, who gives us the GBA cartridge shaped Tablet of Winds that I DEFINITELY feel like was supposed to be more than just what it is in development due to it’s obvious shape. What it is for us is a tablet that lets us record the special signs of the Gold Frogs we encounter, so we can use those frogs as a warp point. Unfortunately there’s only six frogs, and while Past Zodi makes a big deal of how bad that is in video…it’s not THAT bad, every warp point basically puts you NEAR a port. But it just feels extra sucky because of the fact that Mercay Island is a place I’d love to be able to fast travel DIRECTLY too, given it’s the only place you can repair the crane at.

Rounding us the video today, we head to Banan Island to see what mysterious await us here. Turns out it’s just a bad dad hunting for mermaids instead of caring about his gosh darned family. We also find Salvatore, who has a bomb based minigame for us again! This one is super easy, just hitting targets as your boat sails along. I say it’s super easy because I beat it entirely in one shot, but you do have to hit basically every single target as much as you can, and every single 100 point target with no misses. It’s demanding, if not overwhelmingly difficult like the arrow challenge. Back to Romanos’ Dad, it turns out the mermaid won’t appear unless we kill all the monsters outside. We do so, and low and behold she does, either incredibly tanned or someone who’s embraced the ganguro fashion style. Given she’s Jolene’s sister, I’m going to go with the latter. At any rate, in order to actually catch her we need to peg her with the boomerang, one of the only times Link has ever actually hit a real life person in these games, and tell her about the old wayfarer on the island. Turns out she wants to find an old guy and hear him talk about cool stuff, so this all sorta just works out…after a minor mishap where she thinks we sent her to Linebeck instead. It definitely feels weird being reward for helping a dirty old man succeed at abandoning his family to just stare at a (not even real) mermaid all day, but so it goes. We’ve obtained a fishing rod, and will talk about F I S H I N G next time.

Hope you all enjoyed! I’ll see you guys next time for some fishing, and also just progressing the story since I get bored and break my crane. Spoilers.


#33

Oh boy time for Zeld.

Zodi Plays: The Legend of Zelda Phantom Hourglass [17] Goron Time

Video Length: 20:51

Starting us off today, we buy something from Beedle and finally reach 20 points on his silly point card system…which gives us a discount on all further purchases from his shop ship, nice! We also get something in the mail, which thanks to the distorting of time in these written detailings of these videos, I can say what it is right now; the Freebie Card! This allows you to get exactly one free purchase from his shop! This sounds pretty useful, and I’m excited to see if it works on Masked Beetle’s inventory! Because in a good and caring world it will. We also do a little bit more salvage, though I end up breaking the crane which…let’s say “inspires” me to progress the plot a bit, and we also beat up Jolene for 200 rupees! That’s the last reward Linebeck gives us, sadly, so I think future fights with Jolene will leave us with naught but the taste of victory. We also do some fishing, and it’s not the worst minigame in the world, though if you aren’t careful it’ll probably mess up your DS screen. The rewards for fishing are…minimal, as in non existent, but if we get a specific fish we can bring it to the Wayfarer for a more substantial reward! Until we get something new I won’t really be showing the fishing, since nothing really interesting happens during it.

With that all said and done, we head off to the Southeastern quadrant of the map! For no real reason I can think of, we sail towards the nearest island, which happens to be…Goron Island! An actual place of civilization, with the actual return of everyone’s favorite ridiculous stone eating ogres to the Great Sea! Last Gorons we saw where large merchant guys, so this should be fun. Unfortunately, Bellum seems to have other plans, a massive monster attacking us as we try to land on the island! It waterlogs our engines, leaving us a sitting duck for it’s charge attacks and relentless assault of Eye Monsters and blast attacks. Luckily we can shoot the later two things, and they give enough health drops to make the former not AS bad. Still, if you’re unlucky you might get charged a bunch and just bite it. In order to kill this massive dark fish, you have to shoot it’s eyes twice, and there are six eyes total. It’s…not very compelling or even really fun, but I’d honestly argue it’s better than the giant eye plant boss we fought a couple videos ago. With that creature slain, we can make landfall proper on Goron Island!

Immediately we are hit with a…questionable quality remix of the Goron theme. It’s not bad for the most part, but it goes…weird places. We talk to the inhabitants, all of whom introduce us in some way along the lines of “we don’t know who you are but hello”. An interesting thing, to say the least. Less interesting is the child who mentions eating a “wood heart” makes them grow big and strong and courageous, which is…odd. What has the ocean done to you, Goro-friends? We also find a new shop here, wherein we are spoiled on what the next dungeon item is; Bombchus! I entirely forgot Bombchu’s are in the game, and it’s really nice to see one of my favorite Zelda items in another Zelda, because the Bombchu really just doesn’t get all that much screen time in this series. That aside, we make our way through the island to find Bigoron, the village chief. In order to proceed to where the Pure Metal is, we need to prove we want to join the Goron Tribe, and then actually join it. To do the former, we must talk to everyone, a simple task. To do the later, we need…to do a quiz. A random quiz, where the questions are always at least semi randomized, and even includes a “what number question is this?” question in it’s pool. I…very clearly brute forced this in the attempts that I’d be able to pull the answers from aether, and it didn’t go all that well as a result! It’s hard to study when you don’t know what the subject matter is though, so I won’t put too much pressure on Past Zodi for this. Thankfully, we also get rewarded a huge amount of rupees for answering all the questions correctly…only for Bigoron to remove them as an entry fee. The absolute monster. What ever happened to brother-honour!

And that’s it for today. Hope you all enjoyed, next time we’re going to be doing an escort mission with Bigoron’s goron son! That’s going to be fun and not at all bad!


#34

Between Deltarune, the smash direct, and my having to prepare to move, it was hectic getting this out. But I did! I will never miss an update!

Zodi Plays: The Legend of Zelda Phantom Hourglass [18] Fire Temple Plus

Video Length: 24:29

Starting us off today, we play a rather unnecessary bit of padding with Gongoron, having to run around the entire island AGAIN to find him. This is a bit annoying, especially because the story they’re trying to tell here (Gongoron dislikes us and thinks we’re not worth of being a goron, but will later realize we’re good) isn’t actually worth all the annoyance they’re asking us to do here. It’s a really minor thing, all things considered, but after the frustration of last video poor Past Zodi couldn’t help but be a bit annoyed. We eventually corral Gongoron into going the right way, and follow after him to the mini maze before the next dungeon. I actually like this area, since it speaks to a design philosophy I care about. In this game, as you know, bombs and arrows are resources that you have a limited supply of. However, they’re not just used for combat but puzzles as well! So using them for the former always feels bad because you never know when the later will show up. This is why I tend to prefer the systems where you have unlimited resources, like Skyward Sword letting you just harvest Bomb flowers for free bombs. However, in Phantom Hourglass, if you ever NEED bombs, bomb flowers are around! Sometimes they’re in inconvenient spots, but they are there. I feel like if you’re going to have limited resources, this is how you should do it. It’s easier to solve this challenge with regular bombs, but you can use the bomb flowers if you need to. I think it’s a bit more nuanced a way to make puzzles and challenges beyond just having a nut full of preset item drops, which this area also has of course but given what they’re mostly used for I can actually allow it.

At any rate, we make our way through the maze, encountering the first new enemy of the area; blue chus! They’re identical to yellow chu’s except it feels like they take more damage from swords. I don’t actually remember if they do our not, my memory’s shot on these guys, but I’m pretty sure they do. We also encounter Like Like’s, the old slimy bag worm jerks who suck you up and try to eat your shield! I erroneously say they still take three sword hits to kill, regardless of powered up sword or not, but I’m not 100% sure on that. They take two bomb hits, and three arrow hits, but later on I hit one with one bomb and then two sword swings that kills it so I’m really unsure what it’s health status is. If I had to get, enemies internally work on the same heart system we do, and if Like Like’s have say three hearts, each four chunks each, the flame sword is actually powered up by 1.5 instead of by 2x like it says, so instead of doing two full hearts it does a heart and a half, and bombs would just do one heart worth of damage. So that would be the math to make that work, and now I feel nerdy. Well, nerdier. ANYWAY, Goron Temple. It’s full of sand, but not the helpful kind, and it’s got strange wire cubes for doors instead of the same regular door we’ve seen in every other temple. It’s odd, to me, because I know games never really do something NEEDLESSLY, so I’m curious why there’s a difference in doors here compared to every other dungeon.

At any rate, the dungeon also has some new foes for us to tangle with! The armos statues, who act much the same as they did in Wind Waker, stomping around trying to bump into you. They can only be hurt by bombs in this one, and they don’t explode violently when they die, instead becoming inert statues for us to push around for puzzles. We also get Eye Slugs, which is a really weird name for a vaguely cobra esque enemy. I mean yes it has Bellum’s eye on it, but I’d call it like…Eye Rope or something. They are so slow to attack they’re barely a threat. We also have the Hinox, the giant man! They can return fire any bombs near them, and swing those massive arms to send Link flying. If you’re only fighting one they’re kind of a joke, as a single arrow in the eye stuns them long enough to be sliced to ribbons. I’m a bit concerned for you if you don’t have the powered up sword. If it really does actually power up your sword, it uh…it still takes a TON of damage to kill the Hinox, and that’s distressing. Also somewhat distressing, the complete and total lack of tutorials for the little one floor gimmick we get with Gongoron! Sometimes a game should probably tell you what you can do, and this is one of those times.

After slaying the Hinox, you reunite with Gongoron. But he’s separated from us by a wall and some gaps and fences and stuff. However, now we can switch to controlling him! It’s very rare for a Zelda to do this sort of thing, and here we are doing it in this game of all things. Gongoron can roll around to move, being a Goron, allowing him to smash anything in his path at high speeds. Except for Rock Helmet Chu’s, which are apparently stronger than the boulders they hide within as they cannot be smashed by Gongoron’s movements at all! This is especially annoying since the game does not tell you how to attack with Gongoron. Admittedly, there’s not many ways TO interact with things in this game so you can figure it out fairly quickly, and in that sense making the Rocky Helmet Chu’s not destroy-able by the roll makes it clear it’s intended for you to learn how to do it, but it still feels wrong to me. Letting us experiment is all well and good, but with something like this I feel like a tutorial would be appreciated. Heck, the Gorons don’t roll at all in this game so if this is somehow your first Zelda game (entirely possible!) you’d have no idea to expect that. You’d very quickly realize they CAN roll, but it would probably be a bit confusing at first. They could of hinted at that a bit by having Gongoron, during his little hissy fit, roll away instead of run away at high speeds. Just saying.

With Gongoron’s help, we get the dungeon item, and it may be one of my most favorite items in all of Zelda. Second only to the Skull Hammer, it’s the Bombchu! These adorable little mouse grenades are quite great in this game, allowing you to set the course when you put them down. It even stops time for you so you can ensure the path you want it to take. Not only that, you can move after releasing them, allowing for some two pronged attacked! The only limiting factor is that Bombchu’s only come in tens, and getting the Bombchu bag would mean leaving the dungeon which just isn’t happening. The other thing I quite like about Bombchu’s is that they have one of the most clear and concise versions of the iterative design philosophy I mentioned a ton back during Minish Cap. You encounter a variety of puzzles involving the Bombchu, each slowly ramping up in difficulty with what they add and what they remove, and it’s really solidly put together. Honestly, in that sense, Phantom Hourglass is a surprisingly mixed bag of a game to me. I’ve made it pretty clear I’m not the biggest fan of it, not the least of which because the boat controls are honestly kind of miserable and the Ocean King’s Temple is an interesting idea executed rather poorly. But the dungeons have all been pretty consistently good, barring the Ghost Ship and that was really more of a mini dungeon and not a real full dungeon in my eyes. It’s sometimes been said that for Zelda games, the dungeons are the real meat of the game, and for Phantom Hourglass that could not be more true.

But yeah, that’s the video! Hope you all enjoyed, I’ll see you next time for when we beat the Goron Temple and then slowly sort of shuffle my way around to the next destination for a variety of reasons!


#35

Hey. What if…a Zelda? Maybe? I don’t know seems fake. But let’s give it a go.

Zodi Plays: The Legend of Zelda Phantom Hourglass [19] Dongorongo

Video Length: 25:02

In this exciting episode, we finish the final floor of the dungeon to get a hold of the the boss key, which I forget if it’s called Big Key in this or Boss Key. Oops. Regardless, it’s a pretty simple puzzle, throwing our bombchu across the sane, trying to avoid Eye Slugs. Or just killing them outright so you don’t have anything in your way (and get the reward of a treasure chest to boot). There’s not much notable here, it’s just one final bit of puzzling, with some minor combat challenges thrown in. The two Hinox’s together is a bit tricky, but with a quick swording it soon becomes a non-issue. The only real thing of note is the minor disappointment I have with the boss key. When we did the first dungeon I made note of how the game’ll probably make returning to the boss cube difficult in some way. It turns out they’re…not really doing that at all, since the path back has always been short and without any real dangers along it. In this case the only difference is that it’s long instead of short. It does however lead to a cute gossip stone though, as well as the boss of the dunge.on.

Dongorongo, the armoured lizard! This is a pretty cool boss, taking advantage of the dungeon’s one room gimmick in a way that I had forgotten when playing this. As a result I sorta faff about not sure what to do, but that’s entirely on me so I don’t mind as much. Dongorongo has you take control of both Link AND our good friend Gongoron, and boy is making sure I don’t mix up those names difficult. Eye slugs are spawned from the little cracks in the floor, and they’ll go harass Link so be careful of that, and Dongorongo will of course try to crush Gongoron with his charge and his fire breath attack. The charge is the trick to this fight, if he hits a wall when he does it it leaves him open for a Goron-y pounding! Once he falls over, we can direct a little mouse snack into Dongorongo’s mouth to inflict damage. Three times and he is done! Of course…once Link gets across, it turns out the mighty beast isn’t quite finished. The only difference in this phase is that Dongorongo sucks in air for a massive fire blast, and you know what to do with that. Throw in a bomb to knock him out, leaving him vulnerable to slashing at his now exposed weakpoint. Two rotations of that, either due to the prior bombing or my powerful sword, and he explodes into delicious sand and a tasty heart treat.

Then we get to the kinda awkward part of these last three dungeons (and I do mean last three dungeons, we’re nearly done if you can believe it, collectathoning aside). After you beat the boss you walk into the treasure room to acquire the plot coupon…and you just kinda wake up to it and pick it up. You get the standard item get jingle as opposed to anything else, and after you get it a warp point appears for you to leave. There’s no real fanfare or sense of drama when you get the pure metal, you just kinda pick it up, cough awkwardly, and shuffle out of the place. This isn’t really a negative, I don’t dislike the game more for this and honestly a part of me kinda likes the sheer anticlimax of obtaining these macguffins. But it still feels weird and out of tone for Zelda to NOT put emphasis on the important whatevers you spend a whole dungeon hunting for. It gave more gravitas to the boss exploding into two minutes worth of sand, and that’s far less relevant in basically every stretch of the word. I don’t have anything snippy to end this on so I’m going to go to the next paragraph now.

The dungeon finished, we can now rummage through the remaining pockets of Goron Island for any loot we can acquire now. It’s nothing too important, but it lets us use our bombchu so I’m happy for it. We also pick up the bombchu bag upgrade, giving us twenty chances to solve any puzzles that might involve the mouse grenade. Most importantly, as Gongoron asked us, we return to Bigoron for a reward. He gives us a genuinely funny line about how he doesn’t care how we use the pure metal, whether we bake, boil, or forge it, it’s ours and we earned it. Then he pays us back our Goron Fee, plus interest. I can’t believe I’ve been played so completely by these idiot rock men. I love it, never change Gorons. Never change.

Our next destination is…really up to us. We can return to the Ocean King’s Temple, or try and see what’s up with the other island in this quadrant…and it’s pretty clear which is the preferable option. I actually like this, the idea that you do these final dungeons in whatever order you like. Just due to how the game is structured you’ll almost certainly do them the order I’m doing here, but it’s still a choice. I of course opt to check out our next island, but first a little shopping, a little fishing, a little girlfriend punching (for no more rewards, sadly. Bit of a cheap stake, that Linebeck) and checking out the third Traveller’s Ship. In this case, it’s…the Ho Ho Tribe, hailing from Wayaway Island. This is the thing I mentioned when talking about the Treasure Teller, they’ll buy one random type of treasure each day for inflated price, so I’d advise not selling the cheaper treasures at Mercay and instead wait until these guys are hunting for it. I don’t actually know how much they increase the charge by since the first time we meet them they want…something we don’t have, but I’ll be sure to check periodically in the future, just to keep our stores of Rupee up. And that’s really it for today, I hope you all enjoyed! I’ll see you guys next time…for the hell episode. At least for me.


#36

Oh boy it’s time for A Treat.

Zodi Plays: The Legend of Zelda Phantom Hourglass [20] Wrong Girl

Video Length: 20:11

Ever so slightly shorter episode today than regular, for reasons that will make sense as you watch.

But yes, starting us off today, we sail towards the next island…which unfortunately is covered in ice! This is not something we had to do anything special for, we just have to round the island shooting bombs at it until all the ice is gone, occasionally shooting the Eye Monsters that show up to…sort of exist at us menacingly. They don’t actually do anything that I’ve seen and not one has ever actually attacked me. It’s weird. At any rate the ice falls, and we make landfall on the Isle of Ice, which is inhabited by these cute little antler having seal men called Anouki! They waddle and daddle and are…honestly very very stupid, but in an endearing and cute way. Mostly, anyways. We explore the island, getting a taste of what a blind Zelda run would look like, me faffing about talking to everyone to see what’s up. We also receive some mail during this, one from Salvatore of all people and one from the fake mermaid lady. It’s fun, and we get some decent rewards from it.

Eventually we make our way towards the Anouki elder, who tells us some stuff we gotta keep in mind yeah bud? The yook, these yeti type guys, live on the right side of the island, and stole the precious metal that we’re looking for! They also stole one of the Anouki living in the estates, and it’s up to us to go find which Yook is pretending to be. This gives us a rather elaborate “discover the one liar” style puzzle, and thankfully these puzzles are pretty easy. The important thing to keep a look out for in these are contradictions, because the conceit of these is only one person is lying. Which, of course, means everyone else is telling the truth. I realize this sounds like a simple statement but you’d be surprised how important it is to keep in mind. If someone says two people are telling the truth, and someone else says one person is telling the truth that overlaps with one of the two people the first one said, all four people involved in this are telling the truth! This cuts out six down to TWO people! It becomes immediately obvious with even the slightest bit of thought who could be the liar, since the inherent nature of this puzzle is that everyone else is entirely trustworthy.

Which is of course why poor, dumb idiot Past Zodi x’d off the wrong house, confusing her and making her doubt the gut feeling that told her, correctly, who the real culprit is. And thus we get repeatedly and unendingly dunked on by every single NPC in the village. I didn’t show it all since it’s the same dialogue for basically all of them, but if you guess the wrong person in this puzzle…everyone notices. In another world this failure would of replaced our name with Wrong Boy and that is 100% factually a thing they’d do. Thankfully, all we need to do is talk to the elder to reset the puzzle, and we can go back and interrogate the REAL baddy…only for him to blast us with a powerful breath and run away. We pursue, off to the right side of the island!

On the right side of the island, we actually fight the Yook! They come in brown and white varieties, and the wiki SAYS they act differently depending on the fur colour, but they really don’t. The damage they deal and the hits it takes to defeat them are the same, and the strategy to beat them is the same as well. Stand still, let them charge up their breath attack, then feed em an explosive snack. Then slice them up since it only stuns them, but still. We cut our way through the ice flows, and finally reach the next temple. But actually delving into the thing will be for next time. Hope you all enjoyed, I’ll see you guys then!


Also, just as a note…voice commentary will be coming soon. I need to fix my mic since the testing I did with it somehow broke the damn thing the instant I was done, but it’s a thing that’s happening. It’ll almost certainly be there for the next LP, and I’m saying that here to help force myself to do it. Soon, you’ll have to suffer my acerbic wit not in the well formed and thought out text format, but the stuttering nonsense of someone who barely speaks despite having a job as a receptionist.

The reason I’m not going to shift Phantom Hourglass to speech is because I want to keep it consistent. Changing text colour is a change we can allow within an LP, but going from text to voice just feels weird to me to do like that. If that makes sense. Also again the mic just got busted so even if I was going to make the shift over it wouldn’t work.


#37

Oh hey how about…dungeon time.

Zodi Plays: The Legend of Zelda Phantom Hourglass [21] Puzzle Dungeon

Video Length: 21:59

In this episode, we begin the creatively named Temple of Ice! SO, this dungeon has some degree of issue with it. It’s not the worst in the world by any stretch, but some of the bigger rooms are a bit more confusing than they ought to be, and one of the rooms is just play too much to push your way all at once. But let’s tackle this in order, shall we? Our first main puzzle rooms if going about pulling levers in order again, which is definitely iterative design given we’ve done a couple of these throughout the game. What comes next is hitting four simple switches in order with your boomerang, a task that should be well and truly easy were it not for my…sudden leaving of all senses to try and use how and arrow instead. I do think some of this dungeon is a little wrong headed, but this of course I’ll take as all mine.

Enemy wise, we’ve little new in this one. We have ice flavors of bubble and keese, but other wise the only unique enemy is the Stag Beetle, strange armour wearing insects who track you fairly well when trying to dash at you, making it quite hard to avoid them and kill them. Thankfully, with the right timing you can take them down.

Continuing through the temple, we finally come across the dungeon item! The grappling hook is ours, and what a unique weapon it is. We fling it in a direction, extending the length we choose with the stylus, and anything hit that is small enough is drawn towards is. Anything too large to drag to us instead serves to pull us in. They actually put a lot into what is an otherwise relatively simple weapon. You can hook onto chests and pegs and torches to be drawn in, hit enemies like the Rock Helmet Chu’s or Stag Beetles to make them lose their defenses. You can link two objects together to form a tightrope that you can walk on, no balance required! There are further things the rope can do as well, which I believe we get into next like. Mainly you can reflect things off the rope when it’s strung between two places, and you can brush up against the rope to expand the height and length of your jump. All in all, it’s surprising how much they put into this simple item.

Which is of course the problem, when one of the first real challenges you’re to do with it is a rather lengthy timed puzzle involving the tongue switches, which has a gossip stone nearby to encourage you to go about the puzzle in the wrong way, tightroping instead of just dragging yourself across. The lack of clarity, the complication of the timer, and my own rampant stupidity leads to a very annoyed Past Zodi spending a good deal of time and energy trying to move forward in a rather embarrassing way. Finally I do figure it out however, and with that we leave it for Friday.

I hope you all enjoyed this messy episode. I’ll see you guys next time for the conclusion of this fun little dungeon.


#38

Hope you’re ready for t h e h o o k.

Zodi Plays: The Legend of Zelda Phantom Hourglass [22] Gleeok

Video Length: 24:21

While I was a bit of a grump about puzzle iteration last time, this time things couldn’t actually be better! So let’s dive right on in. The floor we’re exploring today features a ton of uses of our good friend grappling hook, showing just how much thought they actually put into this thing. Not only does it let us tightrope over stuff, or grapple to things, it also lets you do super jumps if you push against it! It also reflects projectiles that hit the rope, so we even use it to bounce some arrows back into some eye switches. It’s all pretty cool stuff, and used in enough ways to not be frustrating. One thing that does bother me is the fact that we really only use the reflection property the one time, because there could be a ton off ways to make that work for puzzles and the like, but I understand why they may of just limited it tot he one puzzle.

After a lot of running around beating up monsters and solving rope based puzzles, we finally get our boss key and head towards the boss. This is probably one of my more favorite bosses, because it does feel very actiony. It also makes great use out of the two screen set up, allowing for them to make a cool boss with an elaborate style without taking up too much screen real estate. Gleeok is sadly a little easy, but fighting it is quite fun. It shoots little blasts of ice or fire, and you can reflect the shots back at the opposing element’ed head with a correctly positioned grapple hook. It’ll bust up the dragon’s mask, thought causes one of the heads to chomp at the rope (and you) to try and get rid of it. After doing this a few times, Gleeok will roar and cause a massive wave of water, followed by a bunch of falling ice chunks. There’s a variety of ways to avoid this utilizing the poles/pegs, and after the wave stops you can just do whatever in the water it only pushes you backwards and is not actually dangerous in the slightest. Once both the masks are broken it starts chomping way more often, and starts charging up super blasts. Of course, this leaves it’s tongue hanging, allowing you to smash them head first into the poles, stunning them and leaving them open to a good stabbing.

Gleeok is probably one of my more favorite bosses in this game, and honestly given how good many of the bosses in this are that says something. Maybe it’s just me but something about it feels really good, and it really elevates this dungeon. Truthfully, aside from the massive timed switch run, this dungeon is pretty good. But yeah, with the magic cold rock in hand, we return to the surface to find…no one really cares that much, and the Yook are no longer evil due to Bellum’s influence. That’s good to hear at least! Once that’s done we do a bunch of treasure hunting on the island, plus digging up a TON of rupees because we learn the deep dark secret of the Yook; they don’t trust the bank.

With all that said and done, I hope you all enjoyed! Next time we’ll be heading back into the Ocean King’s Temple, so I’ll see you guys then!


#39

Oh boy, more Zodizelda!

Zodi Plays: The Legend of Zelda Phantom Hourglass [23] F R O G S

Video Length: 32:55

Bit of a long one today folks, got a bit carried away recording and thought more would end up being cut.

In this episode, we…basically just sail around the ocean finding golden frogs to make a note of. I have some degree of trouble getting them all done! But I do get em, every single one except the one that is in the last quadrant of the map, which we’ll attend to at a later date. Golden Frog cyclone warps are…honestly kind of conflicting for me. Not all of them drop you off as close to the nearby islands as I’d like, but overall they’re actually far better than I remember. That being said, having to write them down on the map so you can remember their sign is a very annoying feature. There’s no way to remind yourself what the mark is beyond finding the frog and hammering him with bombs again! And the W with a hat is surprisingly hard to draw in a way that the game registers.

That said, it’s very useful a thing to have, and I’m glad I did the work. Other things I’m glad for; we’ve found a ton of treasure this episode! Lots of treasure maps, lots of orbs of various colours, some ship parts (some of which we already had, though we can sell them at a high price) and even useful things like the Heart Containers! All in all, this was a pretty good bit of clean up we got done…though it sucks that Masked Beedle doesn’t let us use the Freebie Card in his shop ship. That’s the one place you’d actually WANT to use it. Though considering some of the ship parts cost upwards of 6000 rupees…maybe it’s a good thing we can’t use it on his heart container. The last really important thing we get in this episode is our wisdom power, the shield! It powers up our shield, obviously, letting it block fireballs and stuff. It also makes it so that we can walk into enemies to bounce them back with our shield, stunning the smaller enemies (mainly just chu’s, it stuns nothing else!). The strongest thing about the shield though, is that it makes us take half damage from all attacks, and reduces time damage Phantoms inflict down to 15 seconds.

Finally of note in this episode, we find two new minigame islands! The treasure hunting island of Harrow Island, which we will tragically be coming back to to clear it out. It’s an entirely luck based game, and some of the luck is designed to hurt you real bad. If you over extend in this game and try to dig for more treasure then you’re allowed, you get in pretty big trouble! You get one warning, then you need to pay a fine of 100 rupees. Then you get banned, and need to pay 300 rupees to get back in. And if you push it just a bit more, he takes ALL of your rupees. Every last bloody cent, no matter how much you have currently. I may show this off in an alternate universe that isn’t canon, but otherwise don’t expect me to push my luck on that. The other minigame island we find is the…adorable Dee Ess Island. WE can’t really do anything here just yet, but it’s a thing to keep in mind for later!

But yeah, that’s it for today. A long video, but not a lot really happens. But hey, progress is progress. Next time we’re diving back into the Ocean King’s Temple, thought much to my chagrin we’re gonna actually be doing the entire run from the top again because of something really really dumb! I hope you enjoyed, I’ll see you guys next time.


#40

Sick and nosebleed aside, it’s time for more Zeldo!

Zodi Plays: The Legend of Zelda Phantom Hourglass [24] Ocean King’s Temple, More!

Video Length: 21:20

Truthfully very little to say about this one folks. We’re returning to the Ocean King’s Temple to get the final chunk of map to unlock the last piece of the game for us. Looking at it closely, we could have done this at the time we got the other pieces of the map, but ultimately it’s better we didn’t for a variety of reasons, not least of which because at the end of the day, even now we still have to do at least one more run through of half the entire dungeon. But, thankfully, this is the last time it’ll probably be much of a problem thing, I think. We’ll see in a couple weeks, however.

So, let’s talk about the new floors! We’re introduced to new friends here, the curve-horned helmeted Warp Phantoms! If you’re spotted by anyone, all Warp Phantoms will teleport to where you are as soon as they can react. Now, the fun part is…despite this seemingly very powerful ability, Warp Phantoms are also slow! So they’re…basically non-threats. They somehow made an even weaker Phantom, all to balance it’s warp ability. Now if you’re unlucky and get a Phantom Eye on you, they might slow you down enough…but otherwise, Warp Phantom’s are easy to deal with. They’re also suspectable to boulders like anything else. Who needs a Phantom Sword when you can just drop a rock on someone! Ultimately, Warp Phantoms are not a big deal.

The puzzles we deal with in this section are honestly kinda alright, a weird back and forth style maze, and then a very simple “hit these four switches in any order” puzzle. We end it with another bit of Force Gem hunting, but they set it up so you clearly know it’s happening in advance, and you get a safety pot to help you out. I switched back to Lief at some point during this since stunning Phantoms with my sword is just far more effective feeling and very satisfying, and it made a cake walk out of this area…for the most part. Finally, we reach the end of the temple…only to discover the timer is still going, and the room ahead will only open once we can kill Phantoms. My kill count begs to differ, but ah well. We take our north-eastern sea chart, and head on our way.

Hope you enjoyed this one folks. Next time we’re going to be doing the most involved “approaching a dungeon” in the game, the obvious intended final dungeon, and probably some of the actual worst puzzle designs in the game…not due to being bad, but just due to utter stupidity. I hope you’re ready.