What if Twin Peaks was a point-and-click? Let's play Thimbleweed Park

In 1987, a team of developers led by Ron Gilbert and Gary Winnick at what was then Lucasfilm Games released Maniac Mansion, one of the first point-and-click adventure games. Maniac Mansion was surprisingly innovative for its time: while Sierra was still cranking out short, linear games that were padded out by tons of death traps, Maniac Mansion had a system that is to this day relatively unique for an adventure game: having a selection of characters with unique skills that could approach puzzles in different ways. Hardcore Gaming 101 did an excellent article on it, which you can read here: http://www.hardcoregaming101.net/maniac-mansion/

Thimbleweed Park is Ron Gilbert’s second attempt at making a true sequel to Maniac Mansion. It was kickstarted in 2014 and released in March of 2017.

Does it succeed at being a sequel to Maniac Mansion in an era where adventure games are largely relegated to the dark depths of Steam’s indie section? I’d argue that it does… even though I think Maniac Mansion (and Dead at Sea) had a better approach to the idea of having multiple characters with different unique abilities.

In this LP, we’ll be teaming up two FBI agents with a clown and a blatant self-insert to solve a murder. I would recommend that you have at least some understanding of Maniac Mansion and the general culture of adventure games in the early 90s going into this, mostly because of my one real gripe with this game:

Thimbleweed Park drives straight into reference-town almost immediately and never really leaves. While I’ll point out some of the stuff that you’d need to understand a couple of puzzles, truly pointing out everything would triple the length of this LP… which is going to be long enough as it is.

Update 1

Update 2

Update 3



parks a seat-a-roonie in this thread

Upon starting a new game in Thimbleweed Park, you’re given the option of casual or hard mode. To be quite honest, Hard Mode is kind of tedious at parts… but it also contains a lot of content that isn’t in casual mode. For this LP, we’ll be playing on Hard.

The year is 1987… not coincedentally the same year Maniac Mansion was released.

Welcome to the tiny town of Thimbleweed Park, located… somewhere in the United States.

The spritework in this game is fucking amazing, by the way. You can tell a lot of effort was put into it, especially on screens like this one.

Oh hey, it’s another adventure game in which a bum is among the first characters introduced. Unfortunately, this is not a game in which we play as a drunken hobo. What do you think this is, Gravity Rush?

And here comes our protagonist now. The artstyle in this game is very similar to Maniac Mansion’s, and looks surprisingly good given how poorly Maniac Mansion aged.

Boris: “It says to come to the bridge down by the river.”

Yep! Sounds totally legit, nothing at all strange about meeting a bum underneath a bridge. Maybe I was wrong - maybe we ARE playing as a drunken hobo, only he’s undercover as someone who isn’t a drunken hobo so no one sends him to rehab. He’s probably just doing the German accent to throw people off.

Now we get access to the full GUI. We’ve got four items: a note, a wallet, a hotel passcard, and… a stuffed bear? As a side note, this is essentially the standard SCUMM engine GUI - SCUMM stands for Script Creation Utility for Maniac Mansion and was the engine that Maniac Mansion (as well as games like the first Sam & Max, Full Throttle, and Curse of Monkey Island) ran on.

Okay yeah, we’re playing as some guy who is quite clearly too dumb to live. I feel like Alton would have gotten this message and gone “Wait… what?” and that guy’s a dumb asshole who collects Nickelback CDs.

Our first order of business is opening the gate, which is unlocked.

Let’s try talking to the bum. Maybe this really is some kind of secret bum meeting.

Well, that was a productive conversation. Unfortunately, Boris won’t leave this area without finding the person he’s supposed to meet with, so we won’t have a chance to buy some whisky and become an enabler. Detective Halligan this guy is not.

Here, we have our first inventory item of the game - a rock. If hours of playing Rust taught me anything, it’s that you can use the rock to build a house and then eventually have it torched by a group of fifteen year olds wielding AKs.

There’s no visible switch for the light above the sign, so we’ll just have to do this gangsta style.

I didn’t choose the thug life, the thug life chose me. This is very much a Ron Gilbert puzzle, by the way.

Just east of the sign is a patch of really dense overgrowth, which again is pretty amazing as spritework goes.

See that downed tree that’s blocking the sewer? This is the first spot where Hard Mode kicks in - on casual, that tree isn’t there. We can’t do anything with it yet, however. Also, I kind of want to examine the bear before we move on. What’s the deal with that thing, anyway?

…Okay. If you say so. Let’s just move on, and…

Well, Boris is dead and currently being dragged off into the woods, presumably to be eaten and/or buried in a shallow grave. Better restart and maybe grab a gun this time.

Or not.

Man, it sure is Twin Peaks around here. Also, is it just me, or does that body look almost nothing like the guy we just saw get murdered?

By the way, there actually is an FBI office in Albuquerque that has been open since 1949, according to the FBI’s own website. Sure, it’s not the FBI’s “home office” (that would be the one in DC) but it actually wouldn’t be too weird for someone to refer to it that way.

Reyes: “It’s need-to-know.”

Rey: “Look… I like working a case alone.”

Rey: “I especially don’t need some junior agent messing up my investigation.”

Rey: “Especially some junior agent who thinks I don’t know that there isn’t a home office in Albuquerque.”

Rey: “So stay out of my way…”

Rey: “Take a lot of notes…”

Rey: “Sit back and learn…”

Rey: “And I’ll wrap up this case and we can both get the hell out of here.”

Meet Ray and Reyes, our protagonists for the rest of the game. Unlike Maniac Mansion, neither one of them possesses any skills the other doesn’t - but we’ll need both of them to progress through the game.

Reyes: “It’s how it was intended.”

Rey: “I’m sure it was.”

Reyes: “Starting…”

Reyes: “To…”

Reyes: “Pixelate…”

Next update, we’ll start Ray and Reyes on their investigation in earnest, and learn how Thimbleweed Park expects us to handle two characters at once.


Say what you will about Thimbleweed Park, they got someone out there to fix that population sign FAST.

Game Writer A: We need a name for a detective.

Game Writer B: Ray.

Game Writer A: And the second one?

Game Writer B: Ray…es.

Game Writer A: I like it!

Joking aside, the pixelwork is fantastic (those bushes!) and the plot gripping. My attention is gotten.

Once the cutscene ends, the game starts us as Reyes. Let’s start by looking at his inventory.

First up is his badge, with his full name on it.

Second is his notebook. Every playable character in the game has one - they’re used to keep track of objectives, but Ray and Reyes both have notebooks with some extra stuff written in them.

Finally, Reyes has a Polaroid camera. Thankfully we took a look at it here so that Reyes doesn’t look like a complete idiot trying to take a photo of the body with no film in it.

Like Reyes, Ray’s badge also has her full name on it. Naturally they’ve both got the same initials.

The contents of Ray’s notebook are… interesting. Is she CIA? NSA?

The third item in Ray’s inventory is a brick phone, which we have no use for at the moment. The game has a ton of phone numbers we can try calling later - but for right now, we’ll leave it. Finally, Ray is carrying a single-shot film cartridge for the camera. We could have Reyes give her the camera, but I did that on my first playthrough so we’ll do it the other way this time.

On a side note, I actually wondered if Polaroid film really looked like that… and it actually does! As it turns out, the reason they’re so large is that the cartridges contain batteries that power the camera - and the hookup for said batteries is a main cause of failure on older Polaroids.

With a quick “use” command, we have the camera loaded with film and ready to go. By the way, I’m still impressed that the sprite artist bothered to animate Reyes exposing the film.

That’s… only sort of right, Reyes! First, there’s something here we can grab.

If we walk back into the overgrowth, the cursor will pick up on “something odd”. If we look at it…

So… this is the second (as far as I’m aware) Maniac Mansion reference we’ve run into thus far - and according to the in-game timer, this is like six minutes in. This one I’m actually going to explain because it’s kind of obscure.

In Maniac Mansion, one of the items you could pick up was a chainsaw… with no gas in it. There was no gas anywhere to be found in the game, as the chainsaw was meant to be a red herring. From what I understand, a whole bunch of people thought the gas existed, and asked the developers about it.

One year later, in 1988, Lucasfilm Games released another point-and-click called Zack McCracken and the Alien Mindbenders… which had a gas can full of chainsaw gas, but no chainsaw.

Maybe we’ll get lucky here!

Well, crap. There’s no way to throw items away in this game, so we’ll just keep the chainsaw.

There’s also an empty whisky bottle over by the trail sign. This is an item we’re going to need later on. Picking up everything you see in this game is pretty much always the best strategy. There is one other item we can get here, but I’ll leave it for when we actually need it.

Now that we’re done with the body, we can take Reyes up to the highway. Ray will not automatically follow him - there are certain points throughout the game where Ray (and any other characters we may or may not acquire) will teleport to whichever character you’re using. We’ll see one of those coming up.

You might also ask why I’m not immediately picking up the tuna can on the road. The reason is that the highway contains a number of dummy items - the tuna can and the Atari cartridge to the right (which is, of course, one of the E.T. cartridges buried in the desert) are both useless. For the sake of the LP, I’m not going to pick them up.

As Reyes gets about halfway down the highway to Thimbleweed Park proper, he is nearly hit and killed by a plumbing van.

Meet the Pigeon Brothers, who are actually both women. They’re the equivalent to the stewardess from Policenauts, though to a much lesser degree.

Let’s just go for the obvious question first.

I like how Reyes has his eyes closed like he is already thoroughly done with this shit.

Pigeons: “But remember! The signals are very strong tonight.”

You know what, I’m still not asking about the signals.

Header 2

Pigeons: “Dad was expecting to have sons.”

Pigeons: “And he was too cheap to have the van repainted.”

Pigeons: “So we’re just rolling with it until he’s dead.”

Pigeons: “Soon.”

Pigeons: “Shut up, Emily! The signals are very strong tonight.”

Okay, fine. I’ll ask about the signals.

Header 3

Pigeons: “Dark night, deserted road, me in a giant pigeon costume.”

Pigeons: “It was too good to pass up.”

Pigeons: “But the signals are strong tonight.”

This reminds me a lot of the time I sat next to a lady in a waiting room who had just finished watching the latest season of Doctor Who and could not fucking WAIT to tell someone her theories about it. Let’s just get out of here.

Perfect! Let’s just keep going. Hopefully they won’t even notice we’re gone.

There is exactly one item on the roadside that we actually need, and it’s this glass bottle. We’re pretty close to the town now, and…

What was that?

Oh, okay. Ray joins us as soon as we get into town. The sheriff’s office is just to the east of here.

There’s a burned-out building that used to be a watch and violin repair shop, and then an abandoned real estate agency. This is where we get the first phone number in the game that we can call - an in-game hint line. This number is pretty much why Ray’s cell phone exists, so you don’t have to find a pay phone to call if you’re stuck on a puzzle somewhere.

Wow! That was… surprisingly convienient.

Sheriff: “That’s what you are? Feds?”

Sheriff: “It’s hard to miss the government-issue suits.”

We could go for the obvious Twin Peaks reference, but nah.

Sheriff: “The river is so chock-full of chemicals from the old Pillow Factory…”

Sheriff: “…it’s better off there than in a tub of formaldehyde.”

Reyes: “There’s nothing ‘little’ about murder, sir.”

Rey: “Ignore him, he’s new.”

…Hideo? is that you?

Sheriff: “Let’s find the coroner and get you on your way. Wrestling starts at eight.”

Reyes: “I hope he’s talking about on TV.”

Sheriff: “I apologize-a-reno for all the lights being off. We don’t stay open as late as you city slick-a-renos do at night.”

Reyes: “Even for a murder?”

Sheriff: “Especially for murder.”

Oh, Ray. You know full well that any time there’s a gun as an item in an adventure game, it never gets used to shoot anyone. Just look at Sam & Max!

Reyes, still a rookie to the force, ponders that point for a moment. I mean, Donovan and Lucille both had guns, right?

If we head just off to the right, there’s a door to the coroner’s office and… wait… aren’t you the sheriff? Welcome to Ron Gilbert’s absolute favorite joke in this entire game.

Oh, come on! I put up with all those ridiculous accents in Dagger of Amon Ra, but this is just pushing it!

One thing to get used to in this game is that pretty much every device you can think of has a name ending in -Tron 3000 and is powered by a vacuum tube. Clearly, Thimbleweed Park is actually a sequel to Bioshock 2. The sheriff coroner who is absolutely not the same person as the sheriff makes you go through each machine with him, but fortunately, Reyes summarizes that in his notebook.

Now we can get on with the really important questions.

Sheriff: “People do say there is some resemblance around the eyes, but we’re as different as peas-a-who in a pod-a-who!”

Sheriff: “Plus, the sheriff has that annoying ‘a-reno’ he adds to everything. You’ll never hear me doing that-a-who.”

Then there’s sort of a strange question that I think only comes up if you’re controlling Reyes for this.

Sheriff: “Sure did!”

Sheriff: “Four computers positively showed the fire was caused by the factory guard.”

Sheriff: “No doubt-a-who about it.”

Sheriff: “Not these computers. State-of-the-art-a-who computers made by PillowTronics.”

Sheriff: “Absolutely infallible.”

Sheriff: “Whoa now… PillowTronics and its founder, Chuck, are above reproach.”

Sheriff: “Chuck built this town and was a computer and pillow genius.”

Sheriff: “Are the feds looking into this case? It was solved twenty years ago.”

Interestingly, this is accurate to 1987. CompuServe began offering chat rooms in 1980, ten years before they sold consumer internet access. Wikipedia tells me, however, that they charged something like $5 an hour for the privelige. Thankfully that’s not still a thing, or this LP would have bankrupted me already.

Once we ask the coroner about the machines, he’ll tell us to go see the sheriff.

Before we leave, there’s one thing we need to grab from the coroner’s file cabinet - a fingerprint kit! This would be useful, except…

We don’t have any tape. While we’re here, you might also have noticed a small grey dot by Reyes’s feet.

These are specks of dust, which are Thimbleweed Park’s only optional collectible. There is a speck of dust on virtually every screen, each one exactly one pixel in size. I’m not going to bother collecting them for this LP, mainly because I never found them all on my first playthrough of this game.

The sheriff introduces us to the last machine in town hall - the ArrestTron 3000. This is what we feed the reports from the Bloodtron, Fingertron and Facetron into to arrest a suspect.

Once the sheriff leaves to go to his other job as the coroner, we can rifle through his cabinets and find a fingerprint book that contains fingerprints for every resident of Thimbleweed County. Now that we’ve got everything we can get up to this point, let’s strike out for adventure!

A Street is currently blocked by a stream of water from a broken hydrant (tron3000).

Now we need a WC-67 tube. Fortunately, we can find one of those down the town’s other street.

On the way, we pass the bank, which is currently closed…

And the Diner, which is open, but we don’t want to go in there quite yet.

Instead, we want to head right to… the cake store?

The cake store is full of vaccuum tubes. That makes perfect sense.

Reyes: “Based on your sign, I was kind of expecting this place to be a bakery.”

Reyes: “Anyway, I’m Special Agent Reyes. I have some questions for you.”

I’m going to skip the first question, just for now. This update is getting pretty long, and it’s only going to get longer… unless I end it.

Hmm… this seems like too big of a decision for me to make alone. I’ll just let you, the readers, ponder this one for me. I’ll pick whichever one gets the most votes for the next update, and we’ll see where it goes from there.

  • Tubular Tubes ™
  • Tube-tastic ™
  • Tube Town ™
  • You Tube ™

0 voters


I’m honestly surprised that the fourth option didn’t win, given that both playthroughs I’ve seen of this game picked it, but that’s democracy in action.

We’ll see what that does when we return to Ricki’s shop probably a few updates from now.

While we’re here though, there’s a dialog “puzzle” we can solve to get the tube for the burned out fire hydrant.

She’ll ask us for the make and model number of the tube. As far as I know, this is not random - the model number is always WC-67.

Thankfully, Reyes doesn’t need to find a way to pay for it, since Ricki puts it on the town’s account.

With that, we can unlock the other half of the town of Thimbleweed Park. From here, we’re going to do a hard-mode only puzzle that we don’t have to do right now (on my first playthrough, I didn’t know about this until after I’d done almost everything else in town) but that we should totally do because it unlocks fast travel.

I did the next part a little out of order, but the first place I wound up going is the post office, which is just past Ricki’s shop.

The bum from the intro is here, but we can’t really do much with him right now.

The post office has a roll of sticky tape that would be just perfect for our incomplete fingerprinting kit! Unfortunately, the postal worker is kind of a jerk and will only let a federal employee take any.

By the way, I have no idea what that box in the foreground is referencing. It’s not a Maniac Mansion thing as far as I know.

Now that we have some tape, we can start on the next leg of our journey.

One thing that can be a little confusing is that all of the roads leading out of the town proper are labelled the same. If we had tried to, say, go left on the road that took us into town, Reyes would refuse. This road, however, is different. We’ll just go down here and…

Wait, what? Is this another one of those weird broken TV cutscenes like when we first walked into town?

Sheriff: “Yes sir.”

Sheriff: “Yes sir, it is quite annoying.”

Sheriff: “No sir.”

Sheriff: “Yes sir.”

Sheriff: “Yes sir, permanently.”

Sheriff: “Yes sir, violently.”

Sheriff: “No sir.”

Sheriff: “Yes sir.”

Sheriff: “Yes, wrestling was quite good tonight.”

Sheriff: “Goodbye, sir.”

When we come to, Reyes is standing outside the tow’s convienience store. We would need to come here anyway for a different item, so we might as well grab it while we’re here. See the bathroom sign on the left?

We can go in there, and it leads us into this totally not threatening dark room with a pair of glowing red eyes in the corner, not unlike those of the shadowy figure that killed Boris in the intro.

Fortunately, there’s a light switch near the door that reveals it to be a poorly-placed air conditioner. Reyes won’t touch most of the stuff in here…

Except this roll of toilet paper, which we’ll take some of.

Now, let’s head into the Quickie Pal. There’s a sign behind the clerk’s head that we can’t read entirely. Let’s move him over a bit so we can see it.

People from some US states (or who are not from the US) might not recognize this, so I’ll explain briefly.

One of the sort of “vogue” bills for state legislatures in the early 1980s were so-called “bottle bills” that introduced a convoluted system where customers pay a 5-cent deposit on canned and bottled drinks, which they can get back by handing the empty bottles back to the store that sold them. In practice, they’re pretty awkward since all stores are supposed to take back bottles but very few actually do (especially bodegas and other small, family-owned grocery stores) since it takes a lot of time and money to make that work.

Anyway, we can look at the map rack to find out…

If we were on casual mode, the maps would be there, but since we’re on hard mode, we need to take a few extra steps. The first one is returning this bottle.

And that’s the one item we actually need to get a map down. Let’s head out of the Quickie Pal, and…

Two buildings down from the post office is the office for the local newspaper… which also happens to be home to the only remaining map of Thimbleweed county.

Unfortunately, the editor won’t let us touch her map. This is really the first point at which we’ll need to use both Ray and Reyes to solve a puzzle - and remember, this is hard-mode only.

She also really does not like Reyes touching her police scanner and… hey, haven’t we seen one of these before?

Every time we try to touch her scanner, the editor will tell us what she’s waiting to hear on it. Some of these can be pretty funny - on the test run I did for this, she wanted to hear about “A man on the east side of town doing nothing in particular”. Sounds a lot like the newspaper I used to work for.

Thankfully, I left Ray right here before I did this. If we were to send Reyes over here to do this, the editor would be back before he is able to return to the newspaper building and grab the map.

Just like with the hydrant tube, we have to do a short dialogue puzzle here.

Now, given Monkey Island logic, you would think that Reyes could simply take the map while she’s gone and book it - but if we do this, the editor immediately walks back in.

Instead, we have to grab the map off the wall…

Bring it to the copier on the other side of the room, and then insert the nickel we got for returning the bottle. This makes a color copy of the map.

At this point, we could just leave the map where it is and walk out, causing the editor to take her map back but not the copy… but since we’ve already committed the perfect crime, we might as well not leave any evidence.

Unfortunately, we can’t actually USE our map until we show it to the sheriff, who convieniently happens to be hiding in the bushes if you attempt to leave town by going past the Quickie Pal.

Sheriff: “You can’t just go bumbling around the county without a map!”

Sheriff: “You might get lost… and there is a killer-reno on the loose.”

Sheriff: “Well, that looks legit-a-reno.”

Sheriff: “Odd… I thought I…”

Sheriff: “Well… I guess the law is the law…”

That last sentence is actually key. While doing this sequence unlocks the ability to leave town for both Ray and Reyes, fast travel is only accessible by using the map from the inventory. This means that Ray (and any other characters we may or may not encounter in, say, the next update) will need to head to the Quickie Pal to pick up a map before we do much of anything with them.

This is what the map screen looks like. From here, we can fast travel to any location inside or outside of town. We still have plenty of business in town, but this cuts down on travel time by quite a bit.

Next update, we’ll get a hot lead on the killer and meet a new character or two.

1 Like

As soon as we get the map and show it to the sheriff, we go straight into part three. We accomplished roughly a third of the stuff that we could in part two - and this update, we’ll be going back and finishing the rest of that up.

Rey: “The only thing you’re getting close to cracking is my patience with you.”

Reyes: “Let’s work together and I can get on with my…”

Reyes: “I mean, we can get out of this town as quickly as possible.”

So, we could leave the town right now and go visit a couple of other places - but most of those are gated off because we haven’t done a few events yet. Instead, there’s one place on the town’s main street we never visited: the diner. This contains one of the three major events we need before we can truly leave town.

The diner is probably the single biggest Maniac Mansion reference in the game. The woman behind the counter is Sandy, who was kidnapped at the start of Maniac Mansion. She has presumably gotten married to the man on the grill, Dave, who was the protagonist of that game.

Sandy: “Just so you know… that article in the Thimbleweed Nickel about botulism was a smear job.”

Sandy: “So… what can I do for ya, honey?”

Sandy: “Not too much, just scuttlebutt from the morning breakfast crowd. And I don’t want to get into trouble, especially not with a crazy person like him.”

Sandy: “Shut up, Dave!”

Reyes: “We’re the feds, you can trust us. What else do you know?”

Sandy: “Okay honey, but you didn’t hear this from me. I’d look into the crazy clown that lives out at the old circus.”

Sandy: “He’s been out there since the circus closed down years ago. Never takes his makeup off. He’s got serial killer written all over him.”

Sandy: “Was the featured act at Stupendous Brothers Circus. He was about ready to go on stage and meet his well-earned doom.”

Ransome: “Full house after my raunchious Tonight Show appearance. I really got Johnny good, that little jackwad.”

Ransome: “It’s his own fault for not being able to take a joke.”

Ransome: “I’d better get ready to go on stage and insult the crap out of these Thimbleweed idiots.”

Unlike Ray and Reyes, Ransome doesn’t have a notebook. Instead, he has a to-do list.

There’s kind of an ongoing joke that is really poorly explained where Ransome is the only person at the circus who can swear. A lot of his dialogue is beeped out, but when other characters “swear” they actually say the word “beep”.

Ransome’s clown nose is on this doll for some reason. This was honestly a spot where I got kind of stuck the first time I played this because I didn’t expect that to be a thing.

We can also take a look at this bulging poster, which can be removed…

To reveal a safe! Unfortunately, it’s locked and Ransome doesn’t know the combination… and he doesn’t have a thermal drill like those other clowns. That bulletin board looks pretty interesting. Maybe Ransome wrote his safe combination down there.

The first note, the small pink one under the hint flyer, tells us where Ransome’s joke book is. We’ll run into Carney Joe in a few minutes. There’s also that other note…

Ransome: “The number of flags over the Big Top main opening.”

Ransome: “The number of letters in the bottom-left word of the Big Top sign.”

Ransome: “The number of kids that Carney Joe has.”

Ransome: “Must’ve written this when I was on a bender…”

And this is how we get the safe combination. This puzzle is randomized every time you play the game, except for the last clue, which is actualy kind of ingenious as it directs you to Carney Joe in case you didn’t pick up that other note.

Oh, one other neat thing about Ransome’s trailer - the screen actually tilts depending on where Ransome is in the trailer.

Lawyer: “I’m glad I caught you before you went on stage.”

Ransome: “Autographs are $100.”

Lawyer: “Ransome, I’m your business manager and lawyer. I don’t want your autograph.”

Ransome: “Ok, $50 then.”

Lawyer: “I just wanted to let you know that your mistress is waiting at your house in Aspen, and your private jet is being fueled and is ready to whisk you there when the show is over.”

Lawyer: “Also we have a deal worth millions to license a line of toddler Ransome the Clown insult dolls.”

Ransome: “Did you get the liability clause waived?”

Lawyer: “Correct. They will assume all liability when the kids grow up to be beepholes.”

Ransome: “Okay, $25.”

Ransome: “Beep You!”

Welcome to the main thoroughfare of the circus. There’s a mime here on stilts for some reason.

Oh no… Ransome, come on… this isn’t Space Station 13! Clowns and mimes aren’t natural enemies on Earth!

Man, what an asshole. We’ve got more important things to do than push mimes, though.

Here’s the Big Top entrance. We now have two of the numbers to Ransome’s safe combination: the number of flags (4) and the number of letters in the bottom-left word of the sign (8). Now all we need to do is find Carney Joe… who is one screen to the left.

Carney Joe demands a total of $1,138 (one thousand in principal and $138 in interest) to get Ransome’s joke book back. He also reveals to us that he has 4 kids.

Ransome: “Next time I’m setting it to 1-2-3.”

I can’t really convey it in screenshots, but the actual opening of the safe had way more effort put into it than it ever actually needed - the animation will be longer for larger numbers. This should definitely be enough to pay off Carney Joe, and…

We’re still $138 short. Crap. We do still have one area we haven’t explored though, and that’s Ransome’s dressing room.

NOW we’re in business.

Joke book re-acquired. Now we’re all ready to go.

Now we’re in the show proper. This is more or less just a giant tangled thing of Ransome making fun of the audience - I actually had put all of the like… twenty screenshots of this I had up and then lost everything and kind of lost all motivation to finish this update so screw it, we’re moving on.

No matter which options you pick, you’ll eventually wind up with this one.

Ransome: “Or is it your parasitic twin?”

Ransome: “Whatever it is, I hope you bought it a separate ticket!”

Ransome: “Cuz if it’s big enough to ride the beeping rollercoaster by itself, it’s not freeloading in my audience!”

So, this part kind of doesn’t make a whole lot of sense. Who shows up to an insult comic show and doesn’t expect to be insulted?

Ransome: “One of my best shows ever. I hope that ugly old lady with the curse breaks a hip on the way home tonight.”

Ransome: “Now to get this makeup off, hop on my private jet, and go see my mistress Cindy in Aspen.”

Ransome: “This beeping makeup isn’t coming off! Beep you, old lady!”

Lawyer: “Ransome, I’ve got some bad news.”

Ransome: “What do you want, you bald, greedy little beep, can’t you see I’m having a problem!”

Ransome: “Grab a tissue and some rubbing alcohol and help me you beeping beep!”

Lawyer: “Your private jet crashed while trying to land. Your wife found out about your mistress and she’s taking everything you own except the house in Aspen.”

Lawyer: “There was a fire in Aspen and your house burned to the ground.”

Lawyer: “The toy and doll licensing deal is dead and they’re suing you for breach.”

Lawyer: “And one more thing… I quit.”

On the way out…

Anyway, next time, we’ll go attempt to arrest a clown for murder.

Holy crap, it’s been a long time since I updated this. Since then, the developers actually released a DLC pack for this game that removes the beeps from Ransome’s speech. I’ll leave a poll at the end - if people want uncensored Ransome, I’ll buy it.

Now that we’ve gotten our map approved by the sheriff, we can use it to leave town.

Travelling between zones is one of the only annoying parts of this game. If you’ll notice, there’s a little blue figure that represents Reyes - this actually changes color if you’re playing as Ray. The figure takes time to travel between each zone, with the location on the far right side being the longest to reach. We’ll actually need to make that specific journey a few times, and it takes something like five or six seconds to “load”… even though I’m pretty sure it’s not actually masking load times.

Welcome to the circus. There are two kinds of people in this world - JERK and Timmy. Feel free to tag yourself.

Reyes wastes no time going in by himself to arrest this killer clown.

Wait a second, that sounds like…

Oh, it’s just Ransome. I guess we can still question him, even if he’s been cursed to roam the circus until the end of time.

You know what, let’s just go with the blatant Monkey Island reference. In fact, it doesn’t matter what we pick, because…

Reyes will just kind of burst into incoherent gibberish.

Ransome: “What’s the matter, kid? Never seen a man wearing makeup before?”

Reyes: [continued incoherent gibberish]

Ransome: “Look, beepface, you’d better start talking or get outta here! I don’t need another coulrophobic beepwit pissing his pants on my doorstep!”

To progress, we have to have Reyes turn around. If Space Station 13 taught me one thing, it’s that the only thing more dangerous than a clown you can see is a clown you can’t.

Reyes: “I’m sorry about that. I guess I never got over what happened at my 10th birthday…”

Ransome: “Whatever, bozo. Does this mean you’re going to have your back to me the whole time?”

We can question Ransome at this point, but he doesn’t really have a whole lot to say - he doesn’t know anything about the murder. In fact, once we’ve exhausted his dialogue:

This is, in fact, the source of a puzzle much later in the game. Ransome will never let Ray or Reyes into the circus - even once he becomes fully playable.

Speaking of which, if we look at our character select menu, Ransome is there! Let’s switch to him now.

Ransome’s trailer really went to shit over the past decade. At least he still has his to-do list. We should really take a look at that first.

The second objective is the most important. Ransome won’t leave the circus without feeding Little Beeper, whatever that is. In fact, there’s no real hint as to where Little Beeper is. This was one of the first points at which I resorted to using a guide.

Little Beeper is a hamster that Ransome keeps in his microwave. This is one of the Maniac Mansion references I’ll go out of my way to explain, if only because it has kind of an interesting story attached to it.

In Maniac Mansion, the titular mansion was occupied by three residents, one of which was “Weird Ed” Edison, who at that time is a paramilitary survivalist nutjob. Weird Ed is actually in Thimbleweed Park - in fact, you might’ve seen him and not recognized it.

Ed is the guy directly above the kid in the red-and-white striped shirt immediately to the left of the stage.

As I mentioned in the intro post for this game, there were several ways to finish Maniac Mansion depending on which characters you chose at the start of the game. One of those characters is Razor, a punk rocker whose only real “talent” is being a dick.


The only thing Razor could do that no other party member (except one) could is stealing Weird Ed’s pet hamster and putting it in the microwave, then killing it. The fact that this was in the game caused Nintendo to balk when LucasArts tried porting Maniac Mansion to the NES, and is why the hamster’s death is not in that version of the game.

Anyway, this is how you’re supposed to figure out what to do.

Once we leave Ransome’s trailer, there’s a whole bunch of popcorn strewn about the main circus grounds. Considering that the circus apparently closed down the night that Ransome got cursed (which kind of makes no sense unless he owned it), this popcorn has been sitting there for the better part of a decade. This is what we need to feed Little Beeper.

On easy mode, Ransome will pick up the popcorn with his bare hands - but he refuses to do so on hard mode.

On hard mode, we need to collect this popcorn bag that has somehow sat perfectly still on the machine for a decade and use it to pick the popcorn up.

You might notice the rat in the background - the rats will grab a few kernels of popcorn and bring them into the big top while we’re busy walking over to the popcorn machine. Even if we manage to take every single piece of popcorn on the screen, it’ll only fill the bag up halfway, and Ransome refuses to give his hamster anything short of a full bag.

First, we’ll need to go back to Ransome’s trailer and open his fridge to find a wedge of moldy cheese.

Next, we need to follow one of the rats and find out where it is taking the popcorn. I actually did this before I picked up the cheese.

Using the cheese on the hole causes the rats to leave the popcorn as tribute, or something.

Now that the hamster is fed, we’re free to leave the circus… except that I forgot one thing and wound up coming back for it later.

That pink thing on the bulletin board is something you might not even recognize if you don’t, say, order a bunch of imported anime figures to the point where the woman at the post office starts asking questions. Speaking of which, let’s go check my email.

Oh look, time to pay for more figures. You see this? This is why it takes me forever to put out LP updates. Anyway, the pink slip is what the post office in the US leaves when they need you to sign for a package, just in case I have any international readers.

One figure payment later, and we’re out of the circus. Now we can head into town and accomplish Ransome’s second goal of picking up his anime figures from the post office.

On the way there, we can pass the tube store to find out that its name has changed!

We also need to head to the Quickie Pal to take a map. For some reason, only the character you do the initial map puzzle with gets a map - everyone else can leave town at that point, but does not have access to fast travel. I wound up getting one for Ray off-screen after I did this update.

Ransome: “Dear Mr. Clown, we hereby return your defective samples. The wallet seems to be made out of an endangered species of bird, and the candy dispenser sparks whenever you use it. Please do not contact us again.”

Ransome: “What a bunch of beepwads!”

There’s one thing we can do with Ransome right now before we move on to getting our final character in the next update, and it happens right outside the post office. If we park Ransome right outside, we’ll find the bum who was sitting under the bridge where Boris was murdered at the start of the game. Let’s just leave Ransome there and come back with Reyes.

Bum: “I don’t have a wallet. I’m a bum.”

Reyes: “I can see something in your pocket.”

Bum: “Maybe I’m just happy to see you?”

Reyes: “It looks like something with blood on it.”

Bum: “It’s not blood, just river mud!”

Reyes: “Hand over the wallet.”

Bum: “I can’t give it to you. What would I put my money in?”

Bum: “I may be a drunk bum, but I know my rights and you need a warrant!”

Bum: “Find me another wallet and this one is yours. This one’s coming apart anyway. Not like those amazing Ransome the Clown wallets they used to make before his career hit the skids. Ransome was an adulterer, a cheat, and a complete beephole, but he licensed good wallets.”

It’s like he doesn’t notice Ransome standing right next to him. Anyway, there’s one other thing we want to ask him - if he has Boris’s wallet, who knows what else he might have?


Bum: “I have a bit of premium real estate in the nicest part of the sewers.”

We don’t actually need to have Ransome there to progress, but it kind of makes this scene make more sense than if Ransome just walks on screen and psychically knows to give this guy the wallet.

Bum: “A Ransome the Clown wallet! Thanks! Here’s my old one.”

We now have almost everything we need to fill up the machines in the coroner’s office. The last item is in the sewers, but we can’t quite get in there yet. Next update, we’ll find a self-insert who can help us get there.

Also, have a poll.

Uncensor Ransome?

  • Yes
  • No

0 voters

Nah, no need to buy a $2 DLC just to read naughty words.

Somehow, over the previous updates, I completely missed that this was a newish release and thought it was a game from, like, the early 90s. I was very, very confused to why DLC was released between LP updates for a hot minute.

Most places in Thimbleweed County are still locked at this point, but there is still one place we haven’t been - the bus station. As luck would have it, there’s also a person here we haven’t talked to.

Yeah, Reyes just kind of immediately goes there.

Reyes: “I’m sorry ma’am, but I don’t pay for affection.”

Lenore: “Sweetie, I’m not a hooker! Although… there is something about a man in federally mandated polyester that makes me want to forget my wedding vows.”

Lenore: “I’m Lenore Edmund-Mulch, of the famed PillowTronics Edmund family, and I’m waiting for my husband and son to arrive on the bus!”

Lenore: “Oh sweetie, yes, yes yes! So glad someone is finally getting rid of it! But one does hear things, and I have an inkling of who might be connected to this nasty business.”

Yes, clearly Boris was killed by multiple hits from a Splattershot and finished off with a Splat Bomb.

Reyes: “Tell me who you think is connected to the body.”

Lenore: “Well, I hate to cast aspersions, but I suppose it is for the good of the town…”

Reyes: “Tell me what you know.”

Lenore: “Actually… no, I can’t do this. The Edmund family reputation is at stake!”

Reyes: “Ma’am, please tell me what you know.”

Lenore: “Fine! It was my sister, Delores!”

Lenore: “It all started a few years back…”

Oh no, not another flashback! We just got done with one of these!

Welcome to an entire flashback that is going to be nothing but references to both Maniac Mansion and LucasArts/LucasFilm. The bus has now arrived in referencetown and is not going to leave.

Lenore: “Uncle Chuck wanted something else for her, but no… she was too selfish, only wanted to make stupid adventure games…”

Delores: “I’ve got to get out of this town. Uncle Chuck wants me to program his factory computers, but I just want to design games.”

Delores: “Now the only thing I have to look forward to is my favorite computer magazine.”

Delores: “In fact, I should go check the mailbox and see if it’s arrived yet.”

Delores is essentially Ron Gilbert’s self-insert character, though I have no idea how much of her story is actually just his in disguise. The name of the LucasFilm insert is actually a double reference - MMUCUS and FLEM were tools used to make stuff in SCUMM (the engine Maniac Mansion ran on), along with similarly-named tools like BYLE, CYST, SPUTM, and SPIT.

Anyway, the first thing we need to do is go pick up Delores’s magazine. While there are a ton of items in her room that we could pick up now, this is a flashback… meaning we’ll lose anything we pick up as Delores after it’s over.

The mansion Delores lives in is essentially a stand-in for the original Maniac Mansion. There are a ton of rooms upstairs that exist primarily to warp you between the two real locations up there: Delores’s room (the door on the left) and her uncle’s workshop on the other side.

This is the lower floor. The double doors behind Delores lead to the library, while the door underneath leads to the kitchen.

As soon as we leave the mansion, Delores will automatically walk to the mailbox, where the mailman shows up. You might notice a small, red object near the porch that looks like a gas can, specifically one full of chainsaw gas. Yes, we are doing this entire flashback just to get Reyes in there so he can take that gas can.

George: “You still around, Delores? Thought you’d have left this podunk of a town by now.”

Delores: “Yes, hopefully soon. I’m looking for a job at a game company in the big city.”

George: “That’s not going to make your Uncle Chuck happy.”

Delores: “He’ll just have to deal with it. What brings you all the way out here?”

George: “I have your special magazine here.”

Delores: “Oh, I’ve been waiting for that! Thank you!”

George: “Sure. It’s what us dedicated government employees do… walk all the way out into the country to deliver a magazine.”

Soon. For now, we can go inside and take a look at the magazine Delores just got. The other two items, by the way, are Delores’s notebook and a thimbleberry pie. We’ll take a look at those in a bit.

I’m not sure what the “screenshot” on the left is supposed to be, but the one on the right is one of the early X-Wing games.

Delores: “I hear they make movies, too.”

Delores: “This could be a dream come true! I’m going to apply. Interesting… there’s a modem number to call.”

You obviously can’t hear it because it’s a screenshot LP, but as soon as we attempt to move Delores back upstairs, the doorbell starts ringing. She actually won’t go upstairs without answering it.

George: “It’s not like a government employee to make a mistake, but I forgot to deliver this letter for your Uncle Chuck.”

Delores: “He’s busy in his workshop and can’t be disturbed. I’ll take it for him.”

You know what? George can eat shit. Let’s go open that letter.

Welcome to the kitchen. This entire room is a reference to Maniac Mansion - there’s a bunch of dummy items in the fridge which I’ll get to later. All of the cabinets are also empty, except for one.

You can probably figure out exactly where this is going.

This is, I believe, the only place in the entire game that you actually need to use the “close” verb to progress.

Several seconds later, we get the envelope… plus the uncancelled stamps that were on it. Let’s read that letter.

Well, that’s… honestly kinda underwhelming. Franklin is Delores’s dad, who we’ll meet fairly shortly. Oh well, at least we stuck it to the government.

Back in Delores’s room in a screenshot I totally didn’t take before I got the idea to just open the letter outright because that’d be more amusing, we can attempt to apply for the job.

It doesn’t matter which one we go with, but it’s a neat way of learning Delores’s full name.

So, there’s a weird thing here in terms of accuracy which I’m kind of surprised at: none of the states on that list are states that had a bottle return bill in 1987. In case you’re curious, those states are:

California (possible but unlikely as their bill didn’t actually take effect until September of 1987)
New York

There were campaigns in two of the states that are actual options, but neither one ever passed.

West Virginia - First attempted in early 2004, never passed.
Washington - First attempted in 1970, but did not pass. Third (failed) attempt made in 1982.
Wyoming - Bottle bill never attempted
Wisconsin - Bottle bill never attempted

Given that there are literally no games that take place in Connecticut I’m going to go ahead and say Connecticut is the canon answer. It’s probably next to Granbury, that one town that the weather people keep making up when they mispronounce Granby.

The system will then ask a couple of questions (randomly selected) about the actual SCUMM engine. Unfortunately, I, uh… might’ve sequence broken a bit because I’ve played through this part twice and remembered most of the answers and then reloaded the autosave at the start of the flashback. So, let’s pretend we’re not sequence breaking.

Back in the library, we can use the indexing machine to find the book - it’s in Section 3.1. Unfortunately…

The books on the first floor are all Section 1, and the books on the second floor are Section 2. Section 3 is on the third floor… which we can’t access because the staircase is out of order.

Delores won’t climb the stairs as long as they’re out of order. You would think the puzzle would be to find a way to fix the stairs, but…

We can just pick it up and Delores will happily walk upstairs. There’s one other thing I want to show off quickly while we’re down here.

There’s a phone book just off screen that has the names of every person who backed this game on Kickstarter. This would have been a thing had I not accidentally skipped the puzzle that requires it.

I should also mention that every pixel of the bookshelves in this area is a separate “book” written by one of the KS backers.

This is the book we need. As far as I know, all of these things are facts about the actual SCUMM engine.

The game will ask you four questions from the list - which ones it picks are random, but they’re consistent throughout the game, so if you fail you’ll get the same ones.

Unfortunately, the Darkseed-esque printer is out of ink, and there’s no readily available place to get more. This would be a good time to check Delores’s to-do list.

I’ll admit that it’s kind of odd that Delores was a fan of the MSX computer, as those weren’t really popular in the United States.

I kind of went ahead and found Chuck a bit earlier on my other save, but that’s fine. Let’s go ask him if he has any ink.

This is the place, but…

Next update, we’ll finish off Delores’s flashback and finally find a use for that chainsaw.