How Many Brothers Does It Take to Screw in a Lightbulb? Let's Dunk on Two Brothers Until It Breaks

The fullscreen thing is actually not ENTIRELY their fault. I managed to fix it a few updates ago - the reason it crashes is because of the Steam overlay. I could theoretically play in a larger resolution, but I figured that since I’d already done several updates with the standard 320x420 resolution I’d just stick with it. Not to mention that there’s nine different resolution levels, so I’d more than likely fuck up a recording by forgetting what I had it set at last time. I think it resets every time you load the game.

What is their fault is that they clearly knew about this, but didn’t post it anywhere. I had to find out through diving into the Steam discussion board.

Yeah, that’s something I was thinking about. Obviously, some of the problems are related to the movement system, and you can’t really fix those without redoing that from the ground up. But there’s definitely issues they could’ve fixed without even touching it - sure, combat would still be a buggy mess, but at least they could’ve removed some of the softlocking and save-breaking. I’m really not sure why they didn’t at least attempt some minor fixes like that and then maybe address the combat and movement in the remake.

I mean, I’d love for them to succeed and make a good game, but I don’t think it’ll ever happen. I haven’t heard anything from either of the Allansons about releasing a third game and I’m not sure they have it in them. I’ve heard interview Andrew did with a couple of podcasters after YIIK released and it does sound like he had a rough time of it.

That said though, I think they hit rock bottom with YIIK. Two Brothers is buggy and kind of boring. YIIK is actively bad to the point where when I LPed it, I had to shut my brain off for certain parts and just keep clicking the screenshot button. That’s why it’s a puzzle to me that they’re trying to fix YIIK by doing stuff like adding a new character. The problem with YIIK was that there was way too much pointless dialogue, and they’re trying to fix that by adding in more dialogue.

Click Here for Update 9

stdrt 2020-10-14 20-34-04-70

baofusaturn: There’s actually nothing we need to do down here, but there’s an optional weapon at the hot springs south of the graveyard, so might as well.

stdrt 2020-10-14 20-37-47-94

stdrt 2020-10-14 20-37-55-36

stdrt 2020-10-14 20-37-57-64


baofusaturn: How did Brian expect anyone to take this game seriously when he couldn’t even run it through a spell checker? Seriously, I get a game having a couple of typos but this is ridiculous.

Sae: “Unless… are you the new guard? You’re here to keep men out right?”

Roy: “Aye captain!”

Sae: “I’ve heard enough. In fact… I heard you like tridents.”

baofusaturn: I like how that line almost sounds like something Sae would actually say in Persona 5. “I heard you like tridents… where did you learn to use one, and how!? Someone must have told you how to use a trident! There’s no way you could have learned how to use one any other way!”

stdrt 2020-10-14 20-38-10-44

TYPO COUNTER: 43 (Can we please get through more than three lines without a typo? Please?)

stdrt 2020-10-14 20-38-12-34

TYPO COUNTER: 44 (Apparently not.)

stdrt 2020-10-14 20-38-58-60

baofusaturn: I also stopped for a bit to test out the Reaper Scythe. It’s not good. You might notice that blue skeleton - the scythe turns any hearts you get into skeletons that wander around randomly and damage enemies on contact.

baofusaturn: I’m also pretty sure you take more damage with the scythe equipped.

stdrt 2020-10-14 20-40-26-96

stdrt 2020-10-14 20-40-33-66

stdrt 2020-10-14 20-40-49-11

stdrt 2020-10-14 20-40-52-01

stdrt 2020-10-14 20-40-54-51

stdrt 2020-10-14 20-41-01-77

baofusaturn: Oh, PhisPhace is here.

stdrt 2020-10-14 20-41-45-99

baofusaturn: There’s a soccer field here which I think was supposed to be a mini-game at one point. The game gives you a prompt on how to kick the ball (you run into it) but you can’t do anything with it.

stdrt 2020-10-14 20-43-48-24

stdrt 2020-10-14 20-44-20-36

Roy: “Yeah. There is something I’m looking for up there.”

Doloran: “Then you must be looking for despair and mental anguish. This place is CURSED man! There is a reason it has it’s name!”


baofusaturn: Nah, I already played YIIK, thanks.

Roy: “This isn’t my first time going here.”

Doloran: “Yeah? And I’m sure it sucked the first time you went.”

Roy: “…”

Doloran: “Look, if you’re serious about going up there you’re going to need the key.”

Roy: “Where can I find that? Last time I was here there wasn’t even a gate.”

Doloran: “The guy who owned this village locked it up after his kids went missing. They went playing up there one day when he was working late… poor guy.”

Roy: “Where can I find him?”

Doloran: “The pearly gates or the depths of hell? I don’t know. The guy went crazy out of grief and they say he killed himself. I bet only the dead can find out where that key is now.”

baofusaturn: What the fuck is this dialogue? Seriously, what? It sounds like Andrew trying to be David Lynch and just failing miserably.

stdrt 2020-10-14 20-45-28-75

Roy: “Hey, I haven’t seen you up here before. When did you get here…?”

Cursed Man: “I’ve been wandering up here for a while now… I have no idea how long I’ve been up here.”

Roy: “May I ask how you got here?”

Cursed Man: “It’s all a blur. I don’t rightly remember.”

Roy: “I think I’ve heard of you before.”

Cursed Man: “Oh, is that so?”

baofusaturn: Seriously though, what the fuck is this dialog?

Roy: “Did you live in the Cursed Village?”

Cursed Man: “Are you the devil, sir? Have you come to torment me and remind me of my loss? Damn, you sir! Damn you.”

baofusaturn: Pfft. I’d make a Loss edit but this game doesn’t deserve that kind of effort.

Roy: “Please, forgive me. I shouldn’t have been so direct.”

Cursed Man: “No, it’s fine. Who are you?”

Roy: “I am Roy Guarder. I’m a scientist looking for information on this after-life. I believe the Cursed Lands contain a piece of information I need. And I believe you are the only one who knows where the key is.”

Cursed Man: “Haha! I locked that place up for good. I never intended for anyone to get back in there again.”

Roy: “I understand that your kids are in there. What if I promise to look for them?”

Cursed Man: “There is no way they are there anymore. Surely they’ve died. I’ve been waiting here for them to pass through. But they never come.”

Roy: “Wouldn’t you like to know for sure?”

Cursed Man: “You really are persistent, aren’t you? You used my kids to try and get this…”

stdrt 2020-10-14 20-46-18-13

stdrt 2020-10-14 20-46-20-45

stdrt 2020-10-14 20-46-34-13

stdrt 2020-10-14 20-46-38-84

baofusaturn: If you’ll remember from the start of the game, Roy claimed to have spent months traveling through here with his wife.

stdrt 2020-10-18 12-37-07-41

baofusaturn: The Cursed Lands are effectively Two Brothers’ version of Essentia’s mind dungeon in YIIK.

stdrt 2020-10-18 12-37-11-49

stdrt 2020-10-18 12-37-17-27

baofusaturn: Tagline for YIIK right there.

stdrt 2020-10-18 12-37-20-13

baofusaturn: This feels like baby’s first horror game in so many ways.

stdrt 2020-10-18 12-37-48-87

baofusaturn: There’s a long boring stretch of nothing for a while.

stdrt 2020-10-18 12-39-44-17

stdrt 2020-10-18 12-39-49-51

baofusaturn: This puzzle. This fucking puzzle. I’ve seen Voidburger’s videos on some of the bullshit puzzles in Silent Hill 3, but this tops most of them.

baofusaturn: This tells us that we need to “mirror the Square Moon” to get in. The other sign tells us something about Full, Crescent, and Eclipse, which is presumably the phases of whatever the Square Moon is.

baofusaturn: The spheres down below Roy have three states that cycle when hit - you can see all three in the screenshot. So logically, the answer should be the opposite of that: Black for Eclipse, Crescent (because a mirrored crescent moon would still be a crescent moon) and then White for Full. Or so you’d think, anyway.

baofusaturn: Naturally, there’s also no explaining which way it should be oriented, but I figured that it went from left to right.

stdrt 2020-10-18 12-40-46-39

baofusaturn: The answer, for some reason, is black, black, white. I have no idea why.

stdrt 2020-10-18 12-40-50-29

stdrt 2020-10-18 12-41-08-13

stdrt 2020-10-18 12-41-11-49

stdrt 2020-10-18 12-41-17-53

stdrt 2020-10-18 12-41-19-29

stdrt 2020-10-18 12-41-34-95

baofusaturn: There’s three directions we need to go in, and each one has a wall that closes behind Roy once he passes it.

stdrt 2020-10-18 12-41-46-01

baofusaturn: The enemies here don’t really attack you so much as they just kind of wander around. I don’t know if their AI is broken or what.

stdrt 2020-10-18 12-41-58-25

stdrt 2020-10-18 12-43-25-87

stdrt 2020-10-18 12-43-28-75

stdrt 2020-10-18 12-43-30-77

stdrt 2020-10-18 12-43-36-53

stdrt 2020-10-18 12-43-41-77

baofusaturn: Here, we encounter the same enemy, only taller.

stdrt 2020-10-18 12-43-54-17

baofusaturn: The smart thing to do would’ve been to just run past them, but since they’re not immune to arrows I just shot them to death.

stdrt 2020-10-18 12-44-06-17

baofusaturn: There’s a couple of very abrupt screen transitions.

stdrt 2020-10-18 12-44-12-67

baofusaturn: And finally, we have the small version of whatever these things are. The small ones die in a single arrow.

stdrt 2020-10-18 12-44-31-59

stdrt 2020-10-18 12-44-34-73

stdrt 2020-10-18 12-44-55-21

baofusaturn: There’s a small side path you can take to get the Photograph of the Cursed Lands, which is a sidequest item.

stdrt 2020-10-18 12-45-18-43

baofusaturn: A few screens later, and we run into a giant shitpit of enemies. There are so many enemies here that it actually causes the game to lag.

stdrt 2020-10-18 12-45-42-37

baofusaturn: I killed a few of them, and then got to the point where I just said “Fuck it” and ran past everything. The enemies do pretty minimal damage and the lag helps stop them wandering into your path.

stdrt 2020-10-18 12-45-45-13

stdrt 2020-10-18 12-45-55-81

stdrt 2020-10-18 12-46-03-89

baofusaturn: This is the central hub area for the Cursed Lands. We still need to do the West and North sides, but I chose North first.

stdrt 2020-10-18 12-46-20-03

stdrt 2020-10-18 12-46-24-01

stdrt 2020-10-18 12-47-16-83

stdrt 2020-10-18 12-47-23-07

stdrt 2020-10-18 12-47-25-67

stdrt 2020-10-18 12-47-28-73

stdrt 2020-10-18 12-47-31-07

stdrt 2020-10-18 12-47-33-31

stdrt 2020-10-18 12-47-36-29

baofusaturn: Basically, this is a dumb ice puzzle, kind of like the one in whatever that late-game area was in Pokemon Red/Blue.

stdrt 2020-10-18 12-47-42-29

baofusaturn: This one’s really easy. What we have to do is move that one that’s just to the right of Roy down and then to the left…

stdrt 2020-10-18 12-48-06-63

stdrt 2020-10-18 12-48-08-33

stdrt 2020-10-18 12-48-10-39

stdrt 2020-10-18 12-48-11-65

baofusaturn: And then it’s just a matter of pushing the “princess” up, left, and down into the middle. I feel like this entire dungeon is just a collection of stupid, overused puzzles.

stdrt 2020-10-18 12-48-15-33

stdrt 2020-10-18 12-48-31-43

baofusaturn: That puzzle is the entirety of the North area, so let’s go to the last one.

stdrt 2020-10-18 12-48-58-81

stdrt 2020-10-18 12-49-04-73

baofusaturn: This is supposed to be related to that sign about faces or whatever, but the answer is to use the smiling face at it. Using the wrong one takes damage, and I got it on my third try.

stdrt 2020-10-18 12-49-21-03

baofusaturn: We then go through a thing that looks remarkably like that fish building in Egg Harbor.

stdrt 2020-10-18 12-49-26-65

stdrt 2020-10-18 12-49-28-79

stdrt 2020-10-18 12-49-38-77

stdrt 2020-10-18 12-49-44-59

stdrt 2020-10-18 12-49-47-03

baofusaturn: Oh right, I forgot to mention - this entire dungeon has this dumbass “scary” chiptune music that has three repeating notes in the background and it’s just insanely bad.

stdrt 2020-10-18 12-50-00-41

stdrt 2020-10-18 12-50-18-47

stdrt 2020-10-18 12-50-24-15

baofusaturn: Now we go through this room and beat up on this heart. There’s no clear indication that it works - you have to just keep doing it. I thought there was some kind of puzzle involved, but no it just has a lot of HP.

stdrt 2020-10-18 12-50-32-35

stdrt 2020-10-18 12-50-35-37

stdrt 2020-10-18 12-50-41-73

stdrt 2020-10-18 12-50-43-49

stdrt 2020-10-18 12-51-07-41

stdrt 2020-10-18 12-51-10-87

stdrt 2020-10-18 12-51-12-55

stdrt 2020-10-18 12-51-13-95

Typo Counter: 46

stdrt 2020-10-18 12-51-15-33

Typo Counter: 47

stdrt 2020-10-18 12-51-16-61

stdrt 2020-10-18 12-51-23-67

stdrt 2020-10-18 12-51-38-47

stdrt 2020-10-18 12-51-43-37

baofusaturn: A lot of this last area (and honestly a lot of this game) feels like busywork. There’s no reason for this dungeon to be this long.

stdrt 2020-10-18 12-51-57-49

baofusaturn: We go back, and there’s this random NPC who just kind of numbers stations at us for like… 12 textboxes. The first couple textboxes are hexadecimal but I put them into a hex to text thing and nothing came up.

stdrt 2020-10-18 12-52-11-77

baofusaturn: I hope you’re ready for an intentionally broken boss fight… as opposed to the two unintentionally broken ones we’ve run into.

stdrt 2020-10-18 12-52-15-23

baofusaturn: I probably would’ve quit here had I not had the guide to explain this fight to me, because it makes zero fucking sense. There’s this kid who opens that door and shoots a fireball out. He’s unimportant.

stdrt 2020-10-18 12-54-12-59

baofusaturn: I had to really work to get a shot of this, but what you’re supposed to do is go to the other doors and this random enemy will appear when you open them. You have about three frames to hit it before it closes the door.

stdrt 2020-10-18 12-54-20-09

baofusaturn: Once you hit the door enemy enough, you get warped onto this one-tile border area and can’t leave. I thought the game had softlocked again.

stdrt 2020-10-18 12-54-25-15

baofusaturn: Instead, you get into an RPG battle with a Missingno. How original. I’m not sure if the QR code on it does anything.

stdrt 2020-10-18 12-54-32-73

stdrt 2020-10-18 12-54-33-89

stdrt 2020-10-18 12-54-35-67

baofusaturn: Once the Missingno attacks, we can then attack it on the regular game screen. Each attack will cut to an RPG screen.

stdrt 2020-10-18 12-54-41-73

stdrt 2020-10-18 12-55-09-33

baofusaturn: After a few attacks, the game dumps us back in the boss arena, only now there’s a weird zombie boy or whatever.

stdrt 2020-10-18 12-55-18-41

baofusaturn: Attacking it causes it to teleport, but doesn’t actually do anything to the boss’s HP gauge. After a few hits…

stdrt 2020-10-18 12-55-24-17

baofusaturn: We get dumped back on the border and have to fight Missingno again.

stdrt 2020-10-18 12-55-26-55

stdrt 2020-10-18 12-55-27-79

baofusaturn: This is so fucking stupid. So fucking stupid.

stdrt 2020-10-18 12-55-30-55

stdrt 2020-10-18 12-55-41-25

baofusaturn: Once it uses “creepypasta”, the the entire screen fills with garbage. You have to find the real one (it’s directly above Roy) and attack it.

stdrt 2020-10-18 12-56-45-07

baofusaturn: The next phase is more teleporting bullshit. “Sadnessa” spawns behind you and tries to hit Roy with an axe, and the teleport has no animation or anything. This entire phase is basically “stand still and mash attack”.

stdrt 2020-10-18 12-57-17-69

stdrt 2020-10-18 12-57-21-67

baofusaturn: This last phase is by far the worst. It’s basically pure RNG.

stdrt 2020-10-18 12-58-32-41

baofusaturn: You’ll notice that the boss’s health bar has gone up. This is because this phase of the fight consists of a bunch of enemies spawning. The enemies drop hearts, and can eat the hearts to heal.

baofusaturn: Every so often, what happens is that the game will flash and you’ll be back in the middle of the arena with a couple of hearts pre-spawned. If you don’t grab them, the enemies will. This fight took me several minutes due to bad RNG, and I couldn’t initially figure out how they were healing.

stdrt 2020-10-18 13-00-45-45

baofusaturn: This is the final part of the fight. You get three options - in this form, you want to attack the boss.

stdrt 2020-10-18 13-00-57-23

stdrt 2020-10-18 13-01-00-53

baofusaturn: Once it turns into Proto-Jane, you want to use the shield option.

stdrt 2020-10-18 13-01-34-25

stdrt 2020-10-18 13-01-40-01

stdrt 2020-10-18 13-01-42-55

stdrt 2020-10-18 13-01-44-13

stdrt 2020-10-18 13-01-45-61

stdrt 2020-10-18 13-01-47-03

stdrt 2020-10-18 13-01-48-63

stdrt 2020-10-18 13-01-50-07

stdrt 2020-10-18 13-02-00-26

baofusaturn: Well, that shit’s over. Thankfully. Holy fuck that sucked.

stdrt 2020-10-18 13-02-21-48

baofusaturn: Now we get to go through the same area that we were in at the start of the game, because boy does this game love repetition.

stdrt 2020-10-18 13-02-43-62

stdrt 2020-10-18 13-02-48-54

stdrt 2020-10-18 13-02-50-28

Mark: “Is this… is this the one you told me about? The reason you and your wife traveled this far into the Cursed Lands?”

Roy: “It is… when we last arrived here…”

stdrt 2020-10-18 13-02-57-18

Fish King: “Human, please tell me your name.”

Roy: “I am Roy Guarder, and this is my traveling companion Mark Humeny.”

Fish King: “I believe that I owe you an apology. Tell me Guarder, how do you come to walk with the living?”

Roy: “When you attacked me, I found myself in another dimension. A place that men call the ‘Afterlife’. Unlike others, I was able to return to this world.”

baofusaturn: Game, I think we already know who Roy is and how he got here, please stop repeating it.

Fish King: “Indeed… and what of the one who restored my life?”

Roy: “What… what do you mean?”

baofusaturn: God dammit Allanson, Roy saw what happened! Stop acting like everyone’s a fucking goldfish!

Fish King: “I too was in this afterlife. Something called me here… someone perhaps.”

Roy: “I don’t recall much of that day. I remember… the trap… and Jane.”

Fish King: “Why have you come to this place? What do you seek? Did you not find the answer you were seeking many months ago?”

Roy: “I did not… if anything, I just found more questions. I came here to try and find evidence of where the fishmen originated. And then… the trap… you awoke, and I died.”

stdrt 2020-10-18 13-03-32-96

stdrt 2020-10-18 13-03-34-44

Typo Counter: 48

Roy: “I’ve come here seeking an object. An object of a strange color.”

Fish King: “…I know what you are speaking of.”

Roy: “Do you know where I can find it?”

Fish King: “Yes, but first tell me about the fish people. What have my children become?”

Roy: “They are a proud and fascinating race. Their intelligence has helped our world progress rapidly.”

Fish King: “Is that so…? I am proud of them then. When we came to [this side] I was skeptical of what we’d become. But I knew we would spread life around this earth.”

Roy: “[This side]? Where is it that you come from?”

Fish King: “I thought you had abandoned your quest for this knowledge? Is it not the [Spectrum Shard] that you seek now?”

Typo Counter: 49 (technically, that first sentence isn’t a question)

Roy: “I…please. I would like to know both answers.”

Fish King: “Haha! All in good time, Guarder. You came to the one with knowledge of your creation… and you ask me about shards of color! Haha!”

Fish King: “You are a curious race… humans. Always concerned with the next world, never with your own.”

baofusaturn: This could almost be good writing if it hadn’t been done to death.

Roy: “Are you implying that these shards of color are from… the afterlife?”

baofusaturn: God dammit! The fucking bird chief or whatever fucking told you they were! We know this shit already!

Fish King: “I don’t like this term you use… afterlife. You do not possess the words to properly describe a realm… so you pretend that it is not as important as what you experience now.”

baofusaturn: That’s the exact opposite of what you just fucking said! The entire thing about humans only caring about the next world! Fuck!

Roy: “That is not so. That is just the word we use for…”

Fish King: “But I do not come from THIS realm… I come from your afterlife. Is THIS not MY afterlife?”

Roy: “Do you mean to imply that the fish people… come…”

baofusaturn: I mean, yeah, unless they reproduce asexually or are all hand-created by their dipshit fish god who can’t even keep his own story straight.

Fish King: “I do not mean to imply anything, Guarder. I grow tired of this chatter. I knew you’d return.”

Roy: “I had to…”

stdrt 2020-10-18 13-04-33-74

Typo Counter: 49

stdrt 2020-10-18 13-04-35-66

Roy: “Instructed…? BY WHO!?”

stdrt 2020-10-18 13-04-38-36

stdrt 2020-10-18 13-04-40-58

baofusaturn: This entire exchange is around 60 text boxes, and I feel like it could’ve been maybe a tenth as long and still gotten the point across.

stdrt 2020-10-18 13-04-42-94

Typo Counter: 50

Roy: “Can you tell me what it is…? What is this object?”

Fish King: “I do not understand myself. You should take it now. It is not safe here.”

Fish King: “What has become of these lands?”

Mark: “They’re horrible. You’re smart to stay here.”

Roy: “Indeed. This isn’t exactly the most pleasant of places to visit.”

Fish King: “As I expected… Enter, Roy. Take the shard and leave quickly.”

Roy: “But I still have so much to learn from you!”

Fish King: “We will speak at a safer time. Things have changed… we are entering a new era.”

stdrt 2020-10-18 13-05-05-20

stdrt 2020-10-18 13-05-07-16

baofusaturn: Oh boy, time to go inside a giant animal for the second time this game.

stdrt 2020-10-18 13-05-09-88

stdrt 2020-10-18 13-05-18-52

stdrt 2020-10-18 13-05-20-36

stdrt 2020-10-18 13-05-22-10

stdrt 2020-10-18 13-05-24-30

stdrt 2020-10-18 13-05-25-80

baofusaturn: We now have four out of the seven color shards, and this game still doesn’t really have a plot.

stdrt 2020-10-18 13-05-35-66

stdrt 2020-10-18 13-05-37-16

stdrt 2020-10-18 13-05-38-76

baofusaturn: Next time, we’ll tackle a sidequest that is probably going to give us a shitty weapon and get the fifth spectrum shard. Hooray.

Well it makes sense for Missingno to be there, Pokemon Red & Blue came out in 1998 so…wait wrong game. :upside_down_face:

Probably because it’s him trying to be Haruki Murakami and failing…I don’t know about ‘miserably’ but definitely failing.

A rare missed entry in the typo counter.

I just can’t stop asking why so many ideas that could have been done really well were wasted on a game like this.

This may be the dumbest thing I’ve ever seen and this isn’t even the first time I’ve seen it so this isn’t EVEN ORIGINAL.

There’s that fucking Proto-woman concept again. Fucking… nonsensical.

Click Here for Update 10

baofusaturn: Welcome to an update that took maybe a bit over an hour to record but felt like it took ten times that long. Nidoking pointed out that I missed a typo in the last update, so our Typo Counter is actually at 51.

stdrt 2020-10-22 14-42-12-37

baofusaturn: Northeast of the Cursed Lands is the Dark Forest. There’s a sidequest here for a weapon, and also a couple of collectibles.

stdrt 2020-10-22 14-42-16-34

stdrt 2020-10-22 14-43-35-85

baofusaturn: This place is basically a maze, and every screen looks almost identical. I hope you’re also ready for lots of pointless story!

stdrt 2020-10-22 14-43-45-02

baofusaturn: There’s a cave here that’s more or less empty - there’s no enemies in it, no chests, just a path and lots of breakable rocks for no real reason.

stdrt 2020-10-22 14-45-20-13

baofusaturn: At the end is a solitary house, which is how we progress the sidequest.

stdrt 2020-10-22 14-45-26-63

baofusaturn: God dammit of course the Allansons are going to directly reference Deckard Cain. I mean, why not?

Hermit: “Legend claims that many generations ago a vile king ruled over this entire land. One day a young peasant woman witnessed the King’s men butchering her fellow townsmen.”

baofusaturn: I also found out that Deckard Cain was named after someone’s kid. That has to SUCK for that kid.

Hermit: “Their only crime was being unable to pay the ever increasing taxes imposed by the King. The young Hero drew the only weapon that she had.”

stdrt 2020-10-22 14-45-42-39

Typo Counter: 52 (Why is there a full stop in the middle of a sentence?)

Hermit: “However, she was greatly outnumbered and forced to flee into this very forest, where she would begin her true fight against the King.”

baofusaturn: This entire thing sounds like one of the Allansons played NieR (which released in 2010), saw the weapon stories and went “Man, I gotta have that!”

stdrt 2020-10-22 14-45-46-85

Typo Counter: 53

stdrt 2020-10-22 14-45-48-25

stdrt 2020-10-22 14-46-41-90

stdrt 2020-10-22 14-46-48-41

stdrt 2020-10-22 14-46-52-21

Hermit: “However the King grew tired of the young hero so he set a trap. A small raiding party was sent to attack a village that bordered this forest.”

stdrt 2020-10-22 14-46-57-03

Typo Counter: 54 (Sometimes, I wonder if the Allansons are speaking some kind of weird English sub-language where they have no concept of plurals or possessives, or punctuation for that matter.)

baofusaturn: God dammit Allanson you can’t fucking get this right. The weapon stories in Drakengard (and NieR/Automata) were done by someone who fucking knows how to write. They’re maybe four paragraphs long each, and manage to convey a complete story in those four paragraphs. You can’t even go four sentences without a goddamn typo.

Hermit: “Greatly outnumbered the Hero fled into the forest, but she was pursued. The forest - which had been the home to the Hero for many years - did something that the Kings (sic) men could not have foreseen.”

Typo Counter: 55 (See what I mean, Allanson? See what I fucking mean?)

stdrt 2020-10-22 14-47-09-39

stdrt 2020-10-22 14-47-11-39

Typo Counter: 57 (Two typos. Two fucking typos in the same goddamn sentence!)

Hermit: “If you are to continue your journey, you must walk the path of the Hero.”

stdrt 2020-10-22 14-47-27-21

baofusaturn: At this point, everything starts getting very samey. Skeletons start to show up.

stdrt 2020-10-22 14-51-23-62

baofusaturn: There’s a path off this crossroad that has a Great Heart on it. There’s also one that leads to a Mermaid in a Bottle, which I missed. The thing is, the mermaids are glitched anyway so it doesn’t matter.

stdrt 2020-10-22 14-52-21-22

stdrt 2020-10-22 14-53-23-96

Typo Counter: 58

stdrt 2020-10-22 14-53-25-54

stdrt 2020-10-22 14-56-01-70

baofusaturn: Later on, there’s a path that leads to a Worn Staff. I think it’s off the third or fourth set of crossed paths. This area is a nightmare to navigate.

stdrt 2020-10-22 14-56-17-28

stdrt 2020-10-22 14-57-22-04

stdrt 2020-10-22 14-57-48-86

stdrt 2020-10-22 15-00-24-57

stdrt 2020-10-22 15-00-28-59

stdrt 2020-10-22 15-01-24-34

baofusaturn: Wait, did they just use “its” correctly? It’s a fucking miracle.

stdrt 2020-10-22 15-01-26-55

Typo Counter: 59

baofusaturn: And here we have another great example of the Allansons’ favorite method of storytelling, “tell, don’t show”.

Hermit: “They came, trying to kill a girl, and the spirits did not show them any mercy. The men were not able to find the hero in Life, and now they can’t find a way out in Death.”

Hermit: “The tale of our hero is almost at its end. Proceed to the Heart of the Forest, where you shall meet my true form, and learn the sad fate of the Hero.”

stdrt 2020-10-22 15-01-42-88

stdrt 2020-10-22 15-01-46-10

stdrt 2020-10-22 15-01-50-57

Typo Counter: 60

Hermit: “A man dressed in rags, but possessing a great power found his way through the maze.”

stdrt 2020-10-22 15-01-55-89

Typo Counter: 62

Hermit: “Recovering from the chase, our friend was killed by the Dark Man while she slept. The murderer fled from the wrath of the forest as we mourned the loss of our friend. You have proven yourself worthy to the spirits and as such, we have one request.”

stdrt 2020-10-22 15-02-03-34

Typo Counter: 63

stdrt 2020-10-22 15-02-07-50

Hermit: “When you are ready to depart step on the platform to your left.”

stdrt 2020-10-22 15-02-15-72

Typo Counter: 64

stdrt 2020-10-22 15-02-17-27

stdrt 2020-10-22 15-02-21-82

stdrt 2020-10-22 15-02-24-22

stdrt 2020-10-22 15-02-37-50

stdrt 2020-10-22 15-02-44-20

baofusaturn: The Mystic Boomerang, like this game, might almost be good if it wasn’t so poorly coded and developed by anyone who isn’t the Allansons.

baofusaturn: The projectile it fires can’t destroy rocks or plants, and it also works in a very strange way. What happens is that Roy does a melee hit, and then the projectile comes out.

baofusaturn: The melee strike can destroy rocks and grass, but if you do that, it can cause the boomerang to glitch out and become unusable. I thought it was a save-breaking bug, but you can pick a new weapon and it’ll fix itself.

stdrt 2020-10-22 15-02-57-05

Typo Counter: 65

baofusaturn: There’s also a Mermaid in a Bottle behind the tree. I mentioned these were glitched earlier, and here’s how: the game will remember that you picked them up, but won’t actually put them in Roy’s bag - he has a whole section just for them.

baofusaturn: You can get them by save editing, and that’s what I’ll probably do assuming I can’t get the glitch that lets you into the area the mermaids unlock to work.

stdrt 2020-10-22 15-04-43-48

baofusaturn: Now we have to walk all the way back to Excavation Town, halfway across the map. This means backtracking through most of the areas we did in the last few updates.

baofusaturn: Theoretically, you could just go to the Game Over Zone and use the warp that puts you right near Excavation Town, but I’m too afraid of save-breaking bugs.

stdrt 2020-10-22 15-18-29-75

baofusaturn: On the way, I stop back at Egg Harbor to pick up a sidequest item I missed the first time.

stdrt 2020-10-22 15-17-42-48

stdrt 2020-10-22 15-21-40-12

baofusaturn: When we go back to Excavation Town, everyone is gone and there’s this guy trying to sell us tickets to see a dungeon.

stdrt 2020-10-22 15-21-43-16

stdrt 2020-10-22 15-21-49-78

stdrt 2020-10-22 15-21-51-28

stdrt 2020-10-22 15-22-06-75

stdrt 2020-10-22 15-22-11-39

baofusaturn: This is “Dungeon Town” and is the location of the fifth color shard.

stdrt 2020-10-22 15-22-20-25

baofusaturn: Our goal is to press four switches. I believe you can do them in any order.

stdrt 2020-10-22 15-22-38-13

stdrt 2020-10-22 15-23-00-35

baofusaturn: The next room has a breakable wall we can use to get into a new area.

stdrt 2020-10-22 15-23-06-49

stdrt 2020-10-22 15-23-13-79

baofusaturn: Roy can push the boxes to open the way to the next area.

stdrt 2020-10-22 15-23-19-97

stdrt 2020-10-22 15-23-29-43

stdrt 2020-10-22 15-23-34-21

baofusaturn: This isn’t actually another sphere puzzle, even though it looks like it. We just need to keep going to the left.

stdrt 2020-10-22 15-23-47-01

stdrt 2020-10-22 15-23-49-87

stdrt 2020-10-22 15-23-51-99

Typo Counter: 66 (No need for an apostrophe after “gonna”)

stdrt 2020-10-22 15-23-54-71

stdrt 2020-10-22 15-23-58-83

baofusaturn: Down the stairs is an enemy, which kind of took me by surprise.

stdrt 2020-10-22 15-24-03-45

baofusaturn: He’s apparently an old guy in disguise, I guess.

stdrt 2020-10-22 15-24-15-13

Typo Counter: 67

stdrt 2020-10-22 15-24-31-21

stdrt 2020-10-22 15-24-33-03

stdrt 2020-10-22 15-24-36-37

stdrt 2020-10-22 15-24-38-37

stdrt 2020-10-22 15-24-41-99

stdrt 2020-10-22 15-24-45-73

stdrt 2020-10-22 15-24-47-61

stdrt 2020-10-22 15-24-50-43

baofusaturn: This boss is another laughably broken one. If you try to engage her in melee, she grapples Roy to the ground and does a lot of damage, because I’m guessing the Allansons played No More Heroes and thought Bad Girl was the best fight.

stdrt 2020-10-22 15-25-10-21

baofusaturn: All you have to do is stand still and then fire arrows at her from a distance. She won’t move, won’t attack, and will just sit there until she dies.

stdrt 2020-10-22 15-25-36-55

baofusaturn: At 0 HP, you have to walk up to her so she can grab you.

stdrt 2020-10-22 15-25-38-97

stdrt 2020-10-22 15-25-41-15

stdrt 2020-10-22 15-25-42-69

stdrt 2020-10-22 15-25-44-01

stdrt 2020-10-22 15-25-45-19

stdrt 2020-10-22 15-25-47-11

stdrt 2020-10-22 15-25-49-73

baofusaturn: Well, that was fucking stupid. Not as stupid as the scene we’ll see once we clear this dungeon, but still fucking stupid.

stdrt 2020-10-22 15-26-10-97

stdrt 2020-10-22 15-28-01-93

baofusaturn: The next switch is to the right of the main room.

stdrt 2020-10-22 15-28-05-37

stdrt 2020-10-22 15-28-46-23

stdrt 2020-10-22 15-28-47-89

baofusaturn: We can go either north or up the stairs, so I go upstairs first. There’s a single fireball enemy here.

stdrt 2020-10-22 15-29-04-41

baofusaturn: Up the next set of stairs is this guy, who just sits there shooting at bats. I had no idea what the fuck I was supposed to do here.

stdrt 2020-10-22 15-40-12-06

baofusaturn: What you want to do is jump down into the water and hit this specific part of the wall, which is destroyable. I had no idea this was even here until I looked it up in the guide.

stdrt 2020-10-22 15-40-18-17

baofusaturn: Inside is a torch.

stdrt 2020-10-22 15-40-33-97

baofusaturn: For some unknown reason, the torch makes a swarm of bats follow Roy.

stdrt 2020-10-22 15-40-36-62

baofusaturn: What you want to do is just walk up to the dipshit and the bats will push him onto the switch. I didn’t get a shot of it because this was actually the last one I did, and there’s an immediate cut to a different cutscene.

stdrt 2020-10-22 15-30-33-45

baofusaturn: The other route in that last room leads to this room, where we have to push a wall to hit the third switch. There’s another bottle mermaid in here, but whatever.

stdrt 2020-10-22 15-30-52-97

baofusaturn: The back of the wall-pushing room has a hole in it we can use to get to the fourth and final switch.

stdrt 2020-10-22 15-30-57-39

stdrt 2020-10-22 15-31-50-21

baofusaturn: This room is a big, tedious box-pushing ‘puzzle’. I say that in quotations because it’s obvious where everything has to go, and it only goes one way.

stdrt 2020-10-22 15-32-07-15

stdrt 2020-10-22 15-32-09-97

baofusaturn: We get up to the top of the room, and there’s a box in front of a closed door. All of the other boxes in this entire dungeon are empty.

stdrt 2020-10-22 15-32-23-09

baofusaturn: Except this one, which has a sidequest item.

stdrt 2020-10-22 15-32-25-55

baofusaturn: If we try the door, it says that it’s locked from the inside, which makes this seem like a dead end… only it’s not. We’re meant to open this. To do it…

stdrt 2020-10-22 15-32-57-65

baofusaturn: You have to fill three more holes with boxes. I have no idea what the correlation is or how you’re supposed to pick up on that, other than by trying absolutely everything else.

stdrt 2020-10-22 15-33-01-51

stdrt 2020-10-22 15-33-04-55

stdrt 2020-10-22 15-33-13-17

baofusaturn: Hitting the vats next to the witch turns Roy into a fireball monster, which is in full color for some reason.

stdrt 2020-10-22 15-33-53-09

baofusaturn: The fireball monster can clear the rubble in this doorway.

stdrt 2020-10-22 15-33-57-03

stdrt 2020-10-22 15-33-59-89

baofusaturn: It can also drop the weight onto the last switch.

stdrt 2020-10-22 15-34-09-23

baofusaturn: We can also blow up a thing barring the path back down, which will cause that NPC to aggro and immediately kill us.

stdrt 2020-10-22 15-40-41-91

baofusaturn: The door we were trying to open in the first room has now opened.

stdrt 2020-10-22 15-41-26-14

baofusaturn: Beyond it is this puzzle room. There’s no clear indication of what you have to do, but what you have to do is push the NPCs onto the top-right, bottom-right, center left, and the one directly in front of the center left.

stdrt 2020-10-22 15-41-45-06

stdrt 2020-10-22 15-42-11-96

baofusaturn: You have to have Mark sit on the last one, which you do by hitting the inventory button while he’s standing on it.

stdrt 2020-10-22 15-42-33-69

baofusaturn: This opens up in to a cramped hallway full of flying enemies. You can’t run through them - they do a shitload of damage. Instead, you have to just keep firing arrows up the hall to kill everything.

stdrt 2020-10-22 15-42-46-00

stdrt 2020-10-22 15-42-55-77

stdrt 2020-10-22 15-42-58-84

baofusaturn: It’s weird to me that Mark is colored in fully in this dungeon, when he wasn’t in the last one.

stdrt 2020-10-22 15-43-00-86

stdrt 2020-10-22 15-43-03-92

Roy: “Discovered ? Did I not open the door?”

baofusaturn: The weird spacing on that first question mark is a thing the game does. It’s not technically a typo, but it’s borderline.

Ulu: “This is MY dig site! And I ALONE have discovered this amazing new color!”

Roy: “…”

stdrt 2020-10-22 15-43-14-40

Roy: “Professor… this is a part of my research.”

Ulu: “Nobody would believe YOU if you presented this. You have destroyed your reputation with talk of the “afterlife”. But I… I could show the truth to others.”

Ulu: “Roy! You said there were more? Where are they? Do you have them with you right now?”

Roy: “Stand down Ulu!!”

stdrt 2020-10-22 15-43-31-68

Typo Counter: 68 (Abuse of punctuation, 5-yard penalty.)

stdrt 2020-10-22 15-43-35-48

Mighty Figure: “Nor does it belong to the likes of you. Touching this object would surely end your life. Leave this place. You who are bound to this earth are not meant to have this beauty.”

Ulu: “What… what are you!?”

stdrt 2020-10-22 15-43-45-82

stdrt 2020-10-22 15-43-47-20

Roy: “Ulllluuu, don’t lock me in here!”

baofusaturn: The way he’s saying it, it sounds less like he’s shouting and more like he’s an anime girl calling out for her onii-chan.

Mighty Figure: “…Guarder. I need to speak with you.”

Roy: “You know who I am?”

Mighty Figure: “You are the one who walks willingly in to death.”

Roy: “I guess that sounds like me. Why have you come?”

Mighty Figure: “I have come as a warning. These objects you are seeking… they do not belong to this earth. You must be careful…”

stdrt 2020-10-22 15-44-08-70

Typo Counter: 69 (This is not nice. This is not nice at all.)

Mighty Figure: “If something has placed these objects here on the earth, they either want them found… or kept hidden…”

baofusaturn: All this dialogue just feels like filler. It’s like the equivalent of elevator music, or that music you hear in commercials when they don’t want to license real music.

Roy: “I’ve been working under the assumption that an ancient race had built shrines to these objects…”

Mighty Figure: “No such worship of these objects are required…”

Roy: “Do you come from the same place as them?”

Mighty Figure: “I do… but so do others. And some of them may not have my virtuous intentions.”

baofusaturn: How the fuck is it you can spell virtuous, but you can’t use punctuation correctly!?

Mighty Figure: “I ask that you take this object and hide it. Sooner or later you will have to return it…”

Roy: “Where do I return it?”

Mighty Figure: “Exercise caution, Roy. Something is wrong.”

Roy: “Should I keep going?”

Mighty Figure: “In what way, Guarder?”

Roy: “There are more… more of these colored shards.”

Mighty Figure: “I can’t say what the right course of action is here… just remember that these objects are…”

Roy: “Are what?”

Mighty Figure: “They are not what they seem to be. Treat them as though they were sacred.”

baofusaturn: See what I mean? He just said that they’re not a religious thing and not meant to be worshiped, but they’re supposed to be treated as being sacred. That’s the exact opposite of what you just said!

Roy: “Sacred…?”

Mighty Figure: “Go, before the unvirtuous one returns.”

stdrt 2020-10-22 15-44-48-88

stdrt 2020-10-22 15-44-50-46

baofusaturn: To get out, you have to run at the electric barrier until Roy dies.

stdrt 2020-10-22 15-45-24-20

baofusaturn: This will respawn him on the other side. This means we also have to go back through the stupid enemy hallway.

stdrt 2020-10-22 15-46-54-89

Ulu: “GET HIM!!!”

Roy: “Huh?”

stdrt 2020-10-22 15-46-58-81

stdrt 2020-10-22 15-46-59-73

stdrt 2020-10-22 15-47-01-71

stdrt 2020-10-22 15-47-03-51

stdrt 2020-10-22 15-47-04-63

Roy: “Ulu!!”

stdrt 2020-10-22 15-47-11-41

baofusaturn: Ulu then summons a couple of random NPCs to attack, except you can walk right by them. If you stay, though…

stdrt 2020-10-22 15-47-25-17

stdrt 2020-10-22 15-47-26-41

baofusaturn: I’m going to post this whole thing in screenshot form for two reasons. One, it’s basically a shitpost. Two, it has a lot of typos. Also, I’m not sure what the deal with this Amabo guy is.

baofusaturn: He appears in Kickstarter Hell and he’s part of the Krobroc Blade, so he might be based on a friend of the Allansons or a backer or something.

stdrt 2020-10-22 15-47-27-91

stdrt 2020-10-22 15-47-28-97

stdrt 2020-10-22 15-47-30-25

stdrt 2020-10-22 15-47-31-81

Typo Counter: 70

stdrt 2020-10-22 15-47-34-25

stdrt 2020-10-22 15-47-36-63

stdrt 2020-10-22 15-47-39-19

baofusaturn: Yes, he’s giving some kind of half-baked presidential campaign speech. In the middle of whatever dipshit fantasy realm this is.

stdrt 2020-10-22 15-47-41-01

Typo Counter: 71 (It’s La Li Lu LE Lo, dipshit! It’s a romanization of the Japanese alphabet with the r’s swapped so it’s unpronounceable!)

baofusaturn: I saw this, and let me tell you what I did. I sat there flipping off the screen with both hands for a good thirty seconds.

stdrt 2020-10-22 15-47-46-83

Typo Counter: 72

stdrt 2020-10-22 15-47-48-85

stdrt 2020-10-22 15-47-50-41

stdrt 2020-10-22 15-47-52-63

stdrt 2020-10-22 15-47-53-79

stdrt 2020-10-22 15-47-55-07

Typo Counter: 73

stdrt 2020-10-22 15-47-56-19

stdrt 2020-10-22 15-47-57-09

stdrt 2020-10-22 15-47-58-09

stdrt 2020-10-22 15-48-00-93

baofusaturn: This is somehow worse than the Golden Alpaca ever was. This is like a 2008-era 4chan shitpost, back when people were trying to be wacky and random.

baofusaturn: Next time, we’ll visit Fishington and hope I can get through it without the game softlocking.

1 Like

Nah, he’s not trying to be Haruki Murakami. I bought (and then subsequently read and then threw into a garbage can) a copy of After Dark around the end of the YIIK LP. Murakami has this sort of detached shitposting style of writing where it feels like he’s in an elevator with you and trying to give you his pitch for a TV show, and when he realizes you’re not interested he starts mashing the buttons to keep you on the elevator longer, because if you were just around for another 30 seconds you’ll totally understand I swear.

Shit! Fuck! I handled that at the start of the next update, where we go from 51 typos at the start (with that one taken into account) to 73 at the end. I’m guessing that we’re going to break 100 before the game ends.

Oh trust me, you haven’t seen the update I just posted. You called this game a shitpost, and I think you’re absolutely right. It looks and feels like something I’d expect someone from 2008-era 4chan to make, back when being wacky and random was considered funny.

It makes me wonder how long this game was actually in development for: was this a situation where the script was sitting around since 2007 or 2008 and Brian just kind of went with it, even though it was so horribly antiquated and unfunny even for that time? Or is he just that bad at writing?

1 Like

So may things to blabber my ears off at, and they choose to do it over a fucking boomerang?!

Assuming you didn’t make a mistake transcribing this line, this is another typo. The sentence as written is “No such worship are required” when obviously it should be “is required”.

stdrt 2020-10-22 15-44-19-38

Nope, it’s definitely the way it is in the game. That would bring us up to 74 typos.

Go directly to hell.

… what the fuck even just happened??

I’m still mildly distracted by how I can’t really make out anything on the character sprites, either because of the color palette or my eye or both, but all these buildings and a lot of walls look way too detailed for the Game Boy look they’re going for.

Also why is every building an animal?

Click Here for Update 11

stdrt 2020-10-24 00-00-04-19

baofusaturn: We’re back at it again. Drcakey in the thread pointed out that I missed another typo, bringing the Typo Counter to 74. Now it’s time to actually do something in Fishington.

stdrt 2020-10-24 00-00-25-55

baofusaturn: I’m not sure if this was open the entire time and I just didn’t notice it or what, but there’s a ladder in one of the corners we can use now.

stdrt 2020-10-24 00-00-30-83

stdrt 2020-10-24 00-00-33-81

stdrt 2020-10-24 00-00-35-07

stdrt 2020-10-24 00-00-36-91

stdrt 2020-10-24 00-00-38-13

stdrt 2020-10-24 00-00-40-05

stdrt 2020-10-24 00-00-42-83

stdrt 2020-10-24 00-04-44-19

baofusaturn: There’s a great heart down a second pushable ladder.

stdrt 2020-10-24 00-00-56-51

stdrt 2020-10-24 00-01-02-67

stdrt 2020-10-24 00-01-09-05

Typo Counter: 75 (Failed to capitalize after a full stop)

stdrt 2020-10-24 00-01-12-65

baofusaturn: There’s a wall of barrels that we can just walk around because of this game’s horrible movement system.

stdrt 2020-10-24 00-01-17-77

stdrt 2020-10-24 00-01-19-71

stdrt 2020-10-24 00-01-29-21

baofusaturn: On the other side of that strip of land is a fishing pole. We need this for exactly one thing - opening a dungeon.

stdrt 2020-10-24 00-02-03-90

stdrt 2020-10-24 00-02-05-67

baofusaturn: You can fish in a couple of different spots, but there’s no point. The fishing rod is context-sensitive and doing it anywhere but Egg Harbor is pointless.

stdrt 2020-10-24 00-02-17-19

baofusaturn: As far as I can tell, the way it works is that you cast the line, and then it’ll just sit there for a bit until a fish decides to start moving toward it - the fish on the line here was on the opposite side of the pond and just decided to magnetize itself to the hook.

stdrt 2020-10-24 00-07-06-99

stdrt 2020-10-24 00-07-59-11

baofusaturn: Once you pick up the fishing pole, an event opens in Egg Harbor, on the south-west side.

stdrt 2020-10-24 00-08-06-31

baofusaturn: This puts Roy inside a circle of people like it’s a fight in Yakuza or something.

stdrt 2020-10-24 00-08-18-11

baofusaturn: What we’re supposed to do is fish off the pier, except here’s what happens when I press the button.

stdrt 2020-10-24 00-08-20-19

stdrt 2020-10-24 00-08-21-49

stdrt 2020-10-24 00-08-22-55

stdrt 2020-10-24 00-08-23-91

stdrt 2020-10-24 00-08-26-03

stdrt 2020-10-24 00-08-28-11

stdrt 2020-10-24 00-08-29-89

baofusaturn: Roy has a casting animation for fishing, and instead of playing it, the game just cycles through a bunch of unrelated dialogue and then teleports him into the “fishing” position.

stdrt 2020-10-24 00-08-31-53

baofusaturn: Oh, right. If you look at the bottom you’ll notice there’s a mermaid in the pond. You can’t catch it.

stdrt 2020-10-24 00-08-38-99

baofusaturn: As soon as we catch something, a giant fish appears and eats it.

stdrt 2020-10-24 00-08-43-39

stdrt 2020-10-24 00-08-45-17

stdrt 2020-10-24 00-08-47-35

stdrt 2020-10-24 00-08-53-07

stdrt 2020-10-24 00-08-58-93

baofusaturn: And now we have our next dungeon. I’m not sure what (if anything) stops you from doing this the first time you get here, other than maybe a softlock and/or save breaking bug.

stdrt 2020-10-24 00-09-05-14

Typo Counter: 76

baofusaturn: All of the NPCs have their dialog set to this, so technically this is like… 20 or 30 typos.

stdrt 2020-10-24 00-09-13-85

baofusaturn: Note that this is the exact same room they used for when we went inside the Fish King a few updates ago, only without the color.

stdrt 2020-10-24 00-09-16-77

stdrt 2020-10-24 00-09-43-99

stdrt 2020-10-24 00-10-10-87

stdrt 2020-10-24 00-10-13-91

stdrt 2020-10-24 00-10-16-59

stdrt 2020-10-24 00-10-33-97

stdrt 2020-10-24 00-10-37-05

stdrt 2020-10-24 00-10-56-21

baofusaturn: There’s a bottle mermaid here. I actually checked the save file, and of the mermaids we’ve found so far we’ve only actually gotten credit for 3.

stdrt 2020-10-24 00-11-17-19

baofusaturn: This is basically Dodongo’s Cavern from Ocarina of Time, only dumber and shittier.

stdrt 2020-10-24 00-11-32-35

baofusaturn: As soon as we walk in, there’s a thing of regenerating grass - unlike regular grass, this has collision - and some random spider enemies.

stdrt 2020-10-24 00-12-26-87

baofusaturn: The north part has a laser barrier controlled by a switch, which I think was meant to be a puzzle. We can easily bypass it.

stdrt 2020-10-24 00-13-06-73

baofusaturn: What we want to do is push this bomb out of the room and to the left.

stdrt 2020-10-24 00-13-09-49

baofusaturn: This is a process that takes fucking forever - it’s at least thirty or forty seconds of just pushing a bomb.

stdrt 2020-10-24 00-13-18-69

baofusaturn: Doing this clears the boulder in the middle of the room…

stdrt 2020-10-24 00-13-59-35

baofusaturn: Except now there’s a SECOND boulder we have to push the same bomb to. Genius game designer at work right here.

stdrt 2020-10-24 00-14-05-85

baofusaturn: This room. This fucking room. This room is the single most broken piece of shit in the entire game thus far.

stdrt 2020-10-24 00-15-30-29

baofusaturn: The way it works is like this. There’s two switches - one on the left side, and one on the right. There’s also two sets of laser barriers.

stdrt 2020-10-24 00-17-53-31

stdrt 2020-10-24 00-20-40-10

baofusaturn: The way forward involves toggling a switch remotely - the lower barrier needs to be on for these barriers to be off. Sounds simple enough, right? It would be… if this game was coded competently.

stdrt 2020-10-24 00-17-11-53

baofusaturn: It’s hard to get a screenshot of without dying, because there’s invisible enemies on the walls shooting at you at all times, but the left-side switch also toggles a conveyor belt that moves toward the switch.

baofusaturn: What you’re supposed to do is push a bomb near, but not onto, the conveyor belt - for some reason, the bomb has a collision box but no hitbox when it’s on the conveyor. Actually, I know what the reason is and it’s the shitty movement that Brian coded.

baofusaturn: You hit the bomb to light it, and then push it onto the conveyor belt, using the time in between to cross the lower barrier.

stdrt 2020-10-24 00-21-39-80


baofusaturn: Unfortunately, doing this is a fucking nightmare. The bomb will more often than not get caught on the re-growing grass next to the conveyor. It doesn’t help that Mark will continually slash at the invisible wall enemies and can fuck with the switch if you go near it.

baofusaturn: In this case, I got stuck between a bomb and the switch, and couldn’t move. And with this, I believe we’ve passed the number of softlocks I ran into in YIIK.


baofusaturn: Yep, we did.

stdrt 2020-10-24 10-57-18-58

baofusaturn: There’s something fundamentally broken about this puzzle beyond simply the collision, but it took me a minute to understand.

baofusaturn: What happens is that when the bomb explodes, it activates the switch twice. This means that the conveyor belt solution simply doesn’t work - we’d need the belt to be on to get the bomb to hit the switch, and to get it in the right configuration for the bomb to work the conveyor would need to be off.

baofusaturn: What I wound up doing is cheesing the puzzle. See how the bomb is placed in the last screenshot? As it turns out, you can shoot arrows diagonally through the laser barrier.

baofusaturn: It took a bit of finagling, but I managed to put the bomb in a spot near the right-side switch where I could hit it consistently through the laser grid. This is a lot harder than you’d think because the pit tends to eat arrows.

stdrt 2020-10-24 11-02-26-02

baofusaturn: Much better.

stdrt 2020-10-24 11-02-35-18

stdrt 2020-10-24 11-02-39-28

stdrt 2020-10-24 11-02-43-43

baofusaturn: There’s another laser barrier on the conveyor belt here you have to turn off while you’re riding it.

stdrt 2020-10-24 11-02-45-66

stdrt 2020-10-24 11-02-47-24

stdrt 2020-10-24 11-02-52-75

baofusaturn: What I like is how we haven’t even seen this room yet. I had no idea where this was.

stdrt 2020-10-24 11-03-23-02

baofusaturn: The right side is open, and now we need to do another dumb bomb puzzle.

stdrt 2020-10-24 11-03-28-28

stdrt 2020-10-24 13-24-48-16

stdrt 2020-10-24 13-37-47-04

baofusaturn: Now we need to backtrack a couple of rooms to get to where we shut the lasers off. First, we need to go up here - it’s a very narrow passage on the upper-right side.

stdrt 2020-10-24 13-38-22-62

baofusaturn: We then need to kick a bomb through a hole to the lower part of this room, and then walk all the way around.

stdrt 2020-10-24 13-39-19-36

stdrt 2020-10-24 13-39-28-68

stdrt 2020-10-24 13-39-33-40

baofusaturn: Doing this opens a new path into an entirely new kind of hell. You thought the dungeon was bad before, wait until you see this shit.

stdrt 2020-10-24 13-39-37-50

stdrt 2020-10-24 13-39-41-20

baofusaturn: Dropping down the hole puts us in a fight with a mini-boss. The boss will track Roy’s movement left and right, and hitting it will only knock it backward. The guide author had no idea what the shit to do with this boss, but I did.

stdrt 2020-10-24 13-40-02-36

baofusaturn: Behind the boss is a spike wall. You’re supposed to attack it to push it backward into the spikes.

stdrt 2020-10-24 13-40-37-28

stdrt 2020-10-24 13-40-48-16

baofusaturn: This lets us open a door in the main room.

stdrt 2020-10-24 13-40-52-42

stdrt 2020-10-24 13-40-54-02

baofusaturn: Meet the swimsuit. It is part of something even more broken than that bomb puzzle.

stdrt 2020-10-24 13-40-56-12

Typo Counter: 77

stdrt 2020-10-24 13-41-01-94

Typo Counter: 78

baofusaturn: I’m going to skip the tutorial text, except for this typo.

stdrt 2020-10-24 13-41-57-10

baofusaturn: This is the changing room.

stdrt 2020-10-24 13-42-01-50

stdrt 2020-10-24 13-42-05-34

stdrt 2020-10-24 13-43-36-28

baofusaturn: The swimsuit lets us dive in certain pools of water.

stdrt 2020-10-24 13-43-37-83

baofusaturn: The swimming controls are fucking godawful and I died probably six or seven times on the next few parts because they’re fucking unworkable. You have to mash the directional keys to swim, but sometimes the game will just eat your inputs.

stdrt 2020-10-24 13-47-53-55

stdrt 2020-10-24 13-47-58-78

baofusaturn: While underwater, Roy has an air meter instead of a life meter. Running out of air is an instant kill. Mermaids can restore your air bar, just like in Mother 3, a game I’m sure the Allansons never played despite the fan translation that came out in 2009.

stdrt 2020-10-24 13-48-13-47

stdrt 2020-10-24 13-50-06-93

stdrt 2020-10-24 13-50-09-87

baofusaturn: See that little column thing? There’s a few of those in the first area and I could not for the life of me figure out how to destroy them. You basically swim up and mash attack and hope Roy decides to do it.

stdrt 2020-10-24 13-50-15-65

stdrt 2020-10-24 13-50-19-87

stdrt 2020-10-24 13-50-28-79

stdrt 2020-10-24 13-50-35-17

stdrt 2020-10-24 13-50-41-45

stdrt 2020-10-24 13-50-42-87

stdrt 2020-10-24 13-50-44-91

stdrt 2020-10-24 13-50-47-19

stdrt 2020-10-24 13-50-48-81

Typo Counter: 79

stdrt 2020-10-24 13-50-51-31

stdrt 2020-10-24 13-51-41-03

baofusaturn: Back in the last room, we have to dive again. This is where it gets REALLY bad. See that locked sluice gate?

stdrt 2020-10-24 13-51-47-67

stdrt 2020-10-24 13-52-15-88

baofusaturn: We have to pull the chain up to open the door. Because the swimming controls are shit, you will just barely make it through the door.

stdrt 2020-10-24 13-52-35-47

stdrt 2020-10-24 13-52-46-45

stdrt 2020-10-24 13-53-01-36

stdrt 2020-10-24 13-54-26-63

baofusaturn: Who’s ready for another fucking laser puzzle, only this time with swimming?

stdrt 2020-10-24 13-54-30-27

stdrt 2020-10-24 13-55-37-89

baofusaturn: Oh man, special mention to this room for being very broken. You see the switch there? When you enter the room, there’s a horizontal laser right below it. If you miss the switch, it’s basically an autokill because you get stuck in the laser.

baofusaturn: Anyway, we need to swim through that little hole in front of Roy. I don’t know how you’re supposed to know it’s there.

stdrt 2020-10-24 13-55-57-95

stdrt 2020-10-24 13-57-54-12

baofusaturn: This pops us out on the other side of the lasers. We can now progress…

stdrt 2020-10-24 13-59-21-80


baofusaturn: Or not. For some reason, and I have no fucking idea why, the lasers decided to switch position as soon as I went up to the next room.

stdrt 2020-10-24 14-00-36-20

baofusaturn: This room has infinitely spawning enemies and a series of two-way cliffs you can jump up or down.

stdrt 2020-10-24 14-00-46-02

stdrt 2020-10-24 14-01-05-59

stdrt 2020-10-24 14-01-10-56

stdrt 2020-10-24 14-01-11-96

stdrt 2020-10-24 14-01-13-46

stdrt 2020-10-24 14-01-15-70

stdrt 2020-10-24 14-01-18-00

stdrt 2020-10-24 14-01-20-26

stdrt 2020-10-24 14-01-22-62

stdrt 2020-10-24 14-01-24-88

stdrt 2020-10-24 14-01-27-56

stdrt 2020-10-24 14-01-29-82

stdrt 2020-10-24 14-01-32-46

stdrt 2020-10-24 14-01-34-08

stdrt 2020-10-24 14-01-35-59

stdrt 2020-10-24 14-01-39-03

baofusaturn: This boss. This boss is somehow even more broken than the bird temple one was, even though as far as I know it can’t softlock the game.

stdrt 2020-10-24 14-02-47-96

baofusaturn: You attack the tentacles a bit, and then this head shows up. You have about three seconds to do enough damage to it, or it instakills you.

stdrt 2020-10-24 14-02-52-88

stdrt 2020-10-24 15-08-39-58

baofusaturn: By default, the game equips you with the dagger Roy had at the start of the game, and you have no opportunity to switch it. What you have to do is die and then go into Roy’s bag in the Game Over Zone to change weapons to something that can hit the tentacles and do damage.

baofusaturn: Interestingly, the swimsuit fixes a lot of the hitbox issues - when in the swimsuit, Roy will only attack with a single forward stab.

stdrt 2020-10-24 15-08-45-32

stdrt 2020-10-24 15-08-49-07

stdrt 2020-10-24 15-08-54-67

stdrt 2020-10-24 15-09-06-07

stdrt 2020-10-24 15-09-07-93

stdrt 2020-10-24 15-09-10-31

stdrt 2020-10-24 15-09-12-45

stdrt 2020-10-24 15-09-13-59

stdrt 2020-10-24 15-09-15-85

stdrt 2020-10-24 15-09-18-59

Typo Counter: 81 (2x Typo Combo!)

stdrt 2020-10-24 15-09-28-57

stdrt 2020-10-24 15-09-37-35

stdrt 2020-10-24 15-09-39-12

stdrt 2020-10-24 15-09-46-36

stdrt 2020-10-24 15-09-47-87

stdrt 2020-10-24 15-09-50-05

stdrt 2020-10-24 15-09-52-19

baofusaturn: This is technically a typo, since “otherworldly” is usually one word. You know what?

Typo Counter: 82

stdrt 2020-10-24 15-09-54-45

stdrt 2020-10-24 15-09-57-27

Typo Counter: 83

stdrt 2020-10-24 15-10-07-96

baofusaturn: I seriously want to know how the fuck they didn’t mis-spell “possession”.

stdrt 2020-10-24 15-10-12-52

stdrt 2020-10-24 15-10-18-30

stdrt 2020-10-24 15-10-25-08

stdrt 2020-10-24 15-10-30-24

stdrt 2020-10-24 15-10-35-82

Typo Counter: 84

baofusaturn: The “other worldly” thing was kinda borderline. This is definitely a typo.

stdrt 2020-10-24 15-10-41-48

stdrt 2020-10-24 15-10-45-36

stdrt 2020-10-24 15-10-52-58

baofusaturn: To finish this part of the game, we have to go to this bridge.

stdrt 2020-10-24 15-11-12-24

stdrt 2020-10-24 15-11-57-10

stdrt 2020-10-24 15-12-17-86

baofusaturn: Next time, we’ll play as Bivare for a bit. There will be typos.

Oh yeah, no, they’re nowhere NEAR what the Game Boy could handle. I mentioned it in an earlier update, but most developers who make these kind of retro-styled games often put in a lot of work deciding where the acceptable breaks from what the original hardware can do are. In some cases, that’s not at all: see Retro City Rampage, which as far as I remember someone got running on an actual NES.

In others, they make some choices that make sense - the devs behind Shovel Knight did a lot of that.

As for why every building is an animal? Fucked if I know.

This one’s a double typo - “Go no” and “servent”.

Oh, right. I went ahead and updated it, bringing the total to 84 typos.

1 Like

Something a little strange happened while I was reading this update.

I compared screencaps and that is definitely a comma, not a period. But it should be a period, so the typo stands.

After this moment, a power I’ve long kept sealed in the depths of my heart began to stir. A power that should have never been awakened…

This is an eggcorn. The phrase is “heard tell”.

There should be a comma before ‘right’.

‘All-powerful’ needs a hyphen.

Comma before brave.

‘Careful’ has one L!

“Which was only six days away” needs to be set off with a comma.

At this point, I return my katana to its sheath and all the sentences, um…explode in a shower of blood or something.

There’s room for debate with some of the comma additions. But if I were editing anybody’s work (I’m not an editor), I would mark all of these as errors.

1 Like

I like how the game teased us with at least two Jabu Jabu Belly style dungeons, in a game where every single building is some kind of animal, only to pull the rug out from our feet like twice. And then to do it actually, and make a horrible and kinda gross looking area that has, coincidentally, is almost identical to the Jabu Jabu Belly dungeon in Ocarina of Ages, completely with side view swimming.

Oh did I say like I meant burn everything with fire.

I’ve never actually played Oracle of Ages/Seasons past the first couple of minutes. I just found them kinda hard to get into. It does not at all surprise me that they ripped that off though, and I’m willing to bet that it has better swimming controls. I’m trying to remember if Link’s Awakening ever had swimming and the answer escapes me at the moment.

At one point, I was going to count them. Then I realized that if I did that, the typo counter would be well into the four-digit range by this point; the LP would be significantly longer as a result and would require a lot more explanation as to exactly what all the errors are (as otherwise you’d just see the typo counter go up three or four times per line).

The fun part is that for YIIK, the Allansons claimed they had a professional look over the script for corrections… but YIIK was pretty much just as poorly formatted and typo-ridden as Two Brothers was.

1 Like

That’s fair. Also yeah Awakening did have the occasional swimming section like that. It wasn’t great, but it was sure as shit better than this. And speaking of rip offs- the entire fishing thing is definitely lifted from Link’s Awakening as well.